Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to set up a samba share for the first time. My guest share works fine, but I cannot seem to log in as any user. If I enter my unix username and password my mac window just shakes as if an incorrect password was entered.

From what I have read, I thought that because I have security = user set in my smb.conf file, anyone with a unix account on my server would also be able to log into samba. Do I still need to use smbpasswd to allow someone access? Is there an option I can set so that all unix accounts have an associated samba account, with the same password? I believe unix password sync = yes helps with setting something up like that?

share|improve this question

2 Answers 2

It appears that installing libpam-smbpass allows this. I am unsure whether the package installation "converts" existing users.

What I did to see this:

  1. sudo apt-get install libpam-passwd
  2. (as my normal user) passwd <enter appropriate info>
  3. sudo pdbedit -L

And now my user is in the list.

share|improve this answer

This is a follow-up to the answer left by guntbert concerning libpam-smbpass. I found this "how to" in the Ubuntu documentation: Securing a Samba File and Print Server

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.