Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to use Nvidia Optimus on my laptop by using Bumblebee, I have an Intel Core i5 with an Nvidia Geforce GT 630M.

I have followed the instructions on the wiki page at https://wiki.ubuntu.com/Bumblebee, but when trying to run optirun with Firefox (or any other program, like glxspheres), I get the following error:

[ 1921.452820] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ 1921.452905] [ERROR]Aborting because fallback start is disabled.

I have tried googling the issue but I couldn't find any solution that didn't cause more problems.

Thank you for your time.

Here is my bumblebee.conf: http://paste.ubuntu.com/1333324/

share|improve this question
    
Please update your answer providing the content of your bumblebee config file. This can be done using cat /etc/bumblebee/bumblebee.conf | pastebinit, which will give you a link to a webpage with the content of that file. –  Salem Nov 4 '12 at 14:18
    
I have added a link to my bumblebee.conf. Please check the main post. –  nick Nov 4 '12 at 21:59
1  
Run optirun and paste the bottom lines of /var/log/syslog file. Or try to troubleshoot it yourself, wiki.bumblebee-project.org/Troubleshooting –  Lekensteyn Nov 4 '12 at 22:11
add comment

2 Answers 2

It seems I have fixed my problem. I followed Salem's instructions and I downloaded the linux-headers-generic package, and then I reinstalled bbswitch-dkms, nvidia-current and nvidia-settings. Now I can use optirun on glxspheres and get 120fps instead of 60fps. Thank-you all.

share|improve this answer
add comment

Probably your problem is in the configuration of Bumblebee. To configure it you need to edit /etc/bumblebee/bumblebee.conf. To do so, you can run in a terminal, or using Alt+F2

gksu gedit /etc/bumblebee/bumblebee.conf

First, you need to select which driver you want Bumblebee to use: nvidia or nouveau. If you have installed bumblebee-nvidia itś better to use nvidia. Replace Driver= with

Driver=nvidia

Also update the two ocorrences of PMMethod with

PMMethod=none

After rebooting this should make Bumblebee work. If you get a error running optirun regarding permissions you must execute the following command, replacing with your username:

sudo usermod -a -G bumblebee <username>

This will only let you use your NVidia card (ie it will not make nothing regarding power management). If you want Bumblebee to turn off the NVidia card when it is not used you should check the Wiki link you provided, and the TurnCardOffAtExit value in Bumblebee configuration.

Also, you should install bbswitch-dkms (it requires linux-headers-generic )

sudo apt-get install linux-headers-generic
sudo apt-get install bbswitch-dkms
share|improve this answer
    
Okay, so I changed the Driver= to Driver=nvidia in bumblebee.conf, but now it gives me another error, it says the bumblebee daemon has not been started. –  nick Nov 4 '12 at 22:32
    
Have you restarted the system? –  Salem Nov 4 '12 at 22:35
    
Yes. I have restarted the system. –  nick Nov 4 '12 at 22:36
    
ok, then try to run in a terminal the following command: sudo bumblebeed and post the output (use paste.ubuntu.com) –  Salem Nov 4 '12 at 22:38
    
Here is the output of sudo bumblebeed: <paste.ubuntu.com/1333439 > –  nick Nov 4 '12 at 22:42
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.