Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having folders on my desktop. The folders names exceed the folders icons. So that makes me difficult to read the folder names whenever I align all folders in a same line. What I want is to re-size the folders name area to make it readable. Is it possible?

P.S: The same requested for the file names also.

share|improve this question

1 Answer 1

Horizontal Adjustment: Overlapping icons


If this is your first experience with Ubuntu, you might have noticed that icons can be arranged in a way where their file names are overlapping.

overlapping icons

This is not an error, it's a wanted behavior. The user should not be limited in the ways, he can arrange his icons. If he wants the icons to overlap, he should be able to do so.

What you expected is a "snap to grid"-like functionality like you might know from other operating systems. In Ubuntu you are free to place your icons where you want to place them and lock the arrangement. You might call that "lock to place" instead of "lock to grid".

This means you just have to move the icons until they do not overlap anymore. When you are happy with your arrangement, right-click to open the context menu and choose to lock the arrangement.

perfectly aligned icons

Vertical Adjustment: Change the number of displayed lines of icon text


Change the number of displayed lines of icon text

- Install dconf-tools

Open up a terminal with CTRL+ALT+T and install dconf-tools with:

sudo apt-get install dconf-tools

- Change nautilus configuration

Start the dconf editor with the command:

dconf-editor

Then navigate through /org/gnome/nautilus/desktop and change the value for the field-key

text-ellipsis-limit to 0 (if you don't want your file names to be truncated)

or insert a value x > 0 for displaying up to x lines of the file name.

- Restart nautilus

nautilus -q and then open a file-manager window to start nautilus again.


Icon Adjustments: Change details displayed in the icon text


Open a file-manager window and go to Edit -> Settings in the menu. In the Display Tab you can choose which additional should be displayed when the zoom level (Views Tab) is increased. If you choose None, only the name of the folder or file will be displayed.

See the Nautilus Documentation for more info.

share|improve this answer
    
Thank you very much for your answer. But my problem still consists. Is it possible because of that I am using unity desktop? –  Piremerd Piremerd Nov 4 '12 at 13:05
    
I added a picture to show what is done by the configuration edit i showed above. The change affects nautilus, the default file-manager for ubuntu. Or did you try to achieve something different? –  mrcktz Nov 4 '12 at 13:34
    
Folder name's length should appear as much as folder icon's size at maximum on my desktop. If it a long name then should continue on a second line bottom that do not exceeds the icon's size. By the way at the end of each icon's name it explains the icon's type. For example if it is a folder it says "folder" if it as an "image" it says "GIMP image" etc. I would like these extra information disappear too. Actually I wanted to send you a picture of my desktop but I don't know how to send it here. Thank you very much for your assistance. Piremerd. –  Piremerd Piremerd Nov 4 '12 at 14:33
    
It is exactly as shown in your picture but the given file name should not exceed the file icon's size. –  Piremerd Piremerd Nov 4 '12 at 14:44
    
You can increase the default zoom level for your icons. Open a file-manager window, go to Edit->Preferences and play with the default values for the icon view in the Views tab. In the Display tab you can set the additional details that should be displayed after increasing the zoom level. –  mrcktz Nov 4 '12 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.