Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a really hard time trying to get my sharing set up on my 12.04 system.

I've tried both desktop version and server - I'm a bit of a linux n00b, so I need a GUI, command line is beyond me and no time to learn it (not till after I get the shares setup, at least)

My problem is, whenever I try to set permissions in Nautilus, it just reverts back to the default which is to "none"

Basically when I choose an option... it doesn't stick. I can create shares, and it asks me if I want to add permissions automatically - but they do not stick either.

When I go to look at the shared folders in Windows (or even on my Android Phone, or Mac) it gives me permissions errors and doesn't let me log in, despite me clicking "allow guest access"

I have no idea what to do or where to go. I've tried searching forums and google, and I've tried everything I come across - no avail. I've even tried Mint builds to see if it's different, no change there either.

Please help! I really want to setup a server to share my media files and do backups in my house.

Thanks for your help!

share|improve this question

1 Answer 1

Since I am searching on a similar issue, I am going to ask the basic question... Did you start Nautilus as root?

From a Terminal Window:

gksudo nautilus &

I am running 12.10 and the options are all grey'd out unless you have permission to change them. Wondering if that might be a difference. Most likely not, but it was worth a shot :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.