Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi i have a newly installed version of ubuntu 10.10 on my laptop. When i run windows, the fan is working properly and is not making sound. but when i run ubuntu, its making sound and is runnning more faster. what could be the problem. Is there any way of rectifying it.

share|improve this question

3 Answers 3

If the fan is working at full speed, then something is wrong with the power saving features of the computer. This problem is hardware-specific, therefore you would need to provide details of the hardware components.

Indeed, one issue would be the graphics card, especially if it is either AMD/ATI or NVidia. The other issue would be the BIOS of the computer. More often than not, the BIOS does not have correct power saving information that is usable in Linux (while it is usable in Windows). You can google for 'DSDT ubuntu' for more on this.

Therefore, write down the full model number of your computer, and mention which graphics card you have.

Updated: You mention the model number in another reply. I performed the google search and I got several relevant results, such as http://kizwan.blogspot.com/2010/07/acer-aspire-3680-resources-for-mac-os-x.html The easiest thing to do is update the BIOS to the latest version and try again. If that does not fix the issue, come back again.

share|improve this answer
    
@user2124: could u a bit more precise –  user5929 Jan 12 '11 at 8:11
    
@user2124: how to check which graphics card i am using –  user5929 Jan 12 '11 at 8:14
    
Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03) 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GM L Express Integrated Graphics Controller (rev 03) 00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML E xpress Integrated Graphics Controller (rev 03) 00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio C –  user5929 Jan 12 '11 at 8:15
    
Check my update. You should check if there is any BIOS update available from Acer, which could fix these issues in the most painless way. –  user4124 Jan 12 '11 at 8:52

Based off my own experience my fans run in over drive when I don't have proper drivers installed (usually graphics). I would check to see if you have any restricted drivers you could install, and if you do, install them. If you don't, I would check up on your manufacturer's website, find out what kind of graphics card you have and see if you need a driver for it.

I've never had a problem with my CPU causing the fans to go over drive.

share|improve this answer
    
@Dkuntz2: Yes, please check and tell me. –  user5929 Jan 12 '11 at 5:29
    
@Chandru1, check what? I don't know what computer you have, so I can't check it for you. I would be able to give a clearer answer with that information. To check for restricted drivers go to administration -> restricted drivers. –  dkuntz2 Jan 12 '11 at 5:31
    
@Dkuntz2: I have an acer aspire 3680. –  user5929 Jan 12 '11 at 5:33
    
@Dkuntz2: There is no restricted drivers in administration. there is only additional drivers. –  user5929 Jan 12 '11 at 5:35
    
@Chandru1, is it connected to the internet, I've found lots of issues about the wifi not working with Linux, if it's not connected, it might not be getting to the restricted drivers list. –  dkuntz2 Jan 12 '11 at 5:44

Update:

@Chandru1: Based on your model, I found this tutorial that is to enable Frequency Scaling on Celeron:

http://ubuntuforums.org/showthread.php?t=582069

That may possibly fix your problem.

If not, try to check your laptop temperature:

http://www.ubuntuforums.org/showthread.php?t=1200182

which should not be that high (40~60). If it is low, try to slow down the fan manually (following the third link of the bottom) or change manually the frequency of the CPU (second link of the bottom). That may give you a hint.

If it doesn't work, try to install "xserver-xorg-video-intel" video driver as it may be a video related problem, as was suggested by DKuntz2.


Maybe these links can help you:

http://embraceubuntu.com/2005/11/04/enabling-cpu-frequency-scaling/

http://maketecheasier.com/how-to-control-your-cpu-frequency-in-ubuntu/2009/04/10

http://www.thinkwiki.org/wiki/How_to_control_fan_speed

http://ubuntuforums.org/showthread.php?t=1333321

Knowing your laptop model could help to provide more specific solutions.

share|improve this answer
    
@lope: Acer aspire 3680 –  user5929 Jan 12 '11 at 5:17
    
@Chandru1: please read the Update section of this answer. –  lepe Jan 12 '11 at 6:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.