Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi,I have an ASUS K42DY laptop with AMD Phenom II x2, 8 GB Ram , 500 GB Hard Drive and has a didicated ATI RADEON HD 6470M Graphics Card and I'm running Ubuntu 12.04 LTS 64bit on it. I have installed GNOME 3 and also followed this Make Ubuntu look like Mac OS X. I have also installed apps from the software center, getdeb & playdeb all of which worked fine. However, I noticed that Ubuntu freezes after inactivity let's say 1-3hrs. I have already set power setting to never standby or hibernate. This is completely annoying because all I can do is log-out via ctrl+alt+del or manually shut down and reboot my laptop. What should I do? By the way, this happens on all shells Unity, Gnome (even with the basic) and Cairo Dock.I set Swap Space at 8GB during installation.

Any help will be appreciated. Thanks!

share|improve this question

1 Answer 1

The problem could be that U didn't install the additional driver for your graphic card from ubuntu settings manager.Here is what U could do if you don't find any additional driver.

Step 1 : (uninstall the current driver using the terminal)

sudo sh /usr/share/ati/fglrx-uninstall.sh

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx 

Step 2 : (install the ati catalyst using the terminal)

sudo apt-get install unzip

cd /tmp && wget -O amd-12.9-9.00-EDG_Direct.zip http://www2.ati.com/drivers/embedded/9.00-120815a-146426C-EDG_Direct.zip
unzip amd-12.9-9.00-EDG_Direct.zip

chmod +x amd-driver-installer-9.00-x86.x86_64.run

sudo sh amd-driver-installer-9.00-x86.x86_64.run     

Step 3 : (Configure)

sudo aticonfig --initial -f 

Step 4 : reboot

share|improve this answer
    
I'm sorry I forgot to mention that I have installed the "Restricted Drivers" for my graphics card, I have ATI Catalyst. If this is the one that you are referring to.. thanks! –  ix3 Nov 4 '12 at 3:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.