Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running Ubuntu 12.04 w/ VirtualBox installed. I was using the NAT interface to connect to everything. Basically running VBOX for testing some things and a Windows VM for Netflix.. Was back to working in my VMs today and noticed that I was unable to connect to the internet. In the VM settings I'm using the NAT adapter, however I noticed there is no NAT adapter in the Network Settings under Preferences in VBOX.

Not quite sure what happened but wonder what is going on?

I noticed there are some posts about changes DNSMASQ and configuring a bridge mode, but this worked out of the box under 12.04 and since the upgrade this no longers work.

Need some help please

share|improve this question

2 Answers 2

up vote 10 down vote accepted

Known bug of (K)Ubuntu 12.10. Try the following two command lines :

VBoxManage modifyvm "name" --natdnshostresolver1 on
VBoxManage modifyvm "name" --natdnsproxy1 on

if that does not work, install virtual box 4.2 :

Uninstall virtualbox from your computer

sudo apt-get remove virtualbox

also uninstall the guest-addition iso as the 4.2 version contains a new one :

sudo apt-get remove virtualbox-guest-additions-iso

Download and install virtual box 4.2

echo "deb http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list
wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-4.2

When running virtualbox the first time it will ask you to update guest-addition module with the one downloaded.

Enjoy !

share|improve this answer
    
Thanks I'm not on my Ubuntu computer this week, so I'll have to double check this next week –  jjesse Nov 6 '12 at 2:20
    
Not quite sure how to mark this as solved but I was having issues w/ Ubuntu so reloaded to Kubuntu. I followed the steps to install Virtual Box 4.2 and then had to perform the VBoxManage steps in order for it to work correctly. –  jjesse Nov 10 '12 at 19:37
    
Glad that helped you. I encountered the same problem as you on Kubuntu 12.10 and installed the 4.2 version of VirtualBox and it worked. –  Nicolas SAUBAT Nov 12 '12 at 9:44

I upgraded from 12.04 to 12.10 during Saturday and experienced the same. This is rather critical for me to be able to work, so if I cannot get it fixed tomorrow morning, I'll be forced to boot with Win7 at work for the first time in 2 years...

If I change vbox settings to bridged networking for the guest, I'm able to have network, but bridging isn't really the same as NAT...

I've very briefly tried to find if any network settings/policy have been changed in Ubuntu 12.10, but hasn't found anything so far. (Although I believe I saw something in a "commercial" saying something about security-firewall-something-something.)

Anyone?

share|improve this answer
    
alfs, use the solution below it worked for me –  jjesse Nov 10 '12 at 20:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.