Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just recently installed 12.04 and I can't seem to get it to hook up to my wireless network. I tried plugging it in directly and it worked. Any suggestions?

share|improve this question
We need to find out what wireless card you have. please run the following command - lspci | grep Network this should result in a two lines such as this - 03:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300 With that information we should be able to help you. – cprofitt Nov 4 '12 at 4:37

Wireless support can be dependent on your wireless chip. I would recommend using lspci (terminal command) to find your wireless chipset and then google around using that information to see if others have theirs working. good luck!

share|improve this answer
Thanks! Yeah It is just weird cause on Windows it works fine. I've been googling around but I haven't found anything that I either understood or that worked. – Giselle Colon Nov 4 '12 at 0:17

A lot.

  • Is your Wi-Fi supported by Ubuntu? Not all are.
  • Is the device turned on?
  • Is the device blocked? Hardware or software alike can block Wi-Fi.
  • Drivers work as they should?
  • No drivers conflict / shadowing?
  • Are you within reach for your Wi-Fi? Some signals can be blocked surprisingly easy.
  • Is your router ready to work with new device? Some older models may require restarting to "pick" up new kid on the block.

There is more, so perhaps you could extend the question with information what have you tried so far and how it went?

For starters, when I had WiFi troubles I looked here: Ubuntu 10.04 Wireless Troubleshooting

Don't worry that it's for 10.04, identifying devices, commands and other links found there should be a good reference anyway.

More info can be found in community docs

share|improve this answer

It's supported and I said, it sees the network...every time I click on "additional drivers" it crashes and shows an error report. The adapter is 18 inches from the modem; shouldn't be a problem. It already sees it.

The adapter finds my home network and a hidden one (which must be a neighbor's), but every time I click on the home network the window remains blank.

Since the driver thing keeps crashing and it won't read the CD, I'm guessing that's the problem, but I'm new to Ubuntu, so I wondered if there might be something else.

share|improve this answer

I got the same problem. I could connect to my networks before update. Now after update i can see my networks but cannot connect. It looks like it is establishing connection but after couple minutes it gives up. The funny things is that I am using my laptop at various places and different hotspots, and all of the previous networks ive been using did work - now they dont. Except when I'm tethering from my android device - this wireless network works like a charm. My netbook spec: Acer Aspire One - BCM4313 802.11b/g/n Wireless LAN Controller Broadcom Corporation. Any suggestions? Please help. This is really driving me bananas! Btw i tried deleteing and connecting to these networks multiple times and no change.

share|improve this answer
Welcome to Ask Ubuntu! This doesn't answer the original question. If you have another question, please ask it by clicking the Ask Question button. – Kevin Bowen Feb 9 '13 at 4:34

protected by Community Mar 2 '13 at 18:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.