Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After my upgrade from Ubuntu 12.04 LTS to 12.10, Transmission won't download from an anti-leech tracker (ALT). If I download a torrent via Magnet Link, everything works fine, but if I download from that ALT, it doesn't.

The tracker will return OK and also return the List of Seeders and Leechers (each greater than 20), but no peers to download from are returned. Everything worked fine previous to the upgrade.

For testing purposes I downloaded KTorrent. The same occured there.

I had Transmission running for as long as 10 hours and no success.

My port is open and even if the firewall is disabled, this still happens.

share|improve this question
    
Unfortunatley I'm still searching for a solution. though it really is a Ubuntu-related problem. If I boot Windows on the same machine, at least uTorrent will connect to the ALT. –  Marvin Dickhaus Dec 14 '12 at 16:40
    
Did you try ktorrent, deluge or qbittorrent, just to see if it is only with transmission or all torrent clients? –  Luis Alvarado Dec 14 '12 at 22:31
1  
@LuisAlvarado I already stated this im my question. "For testing purposes I downloaded KTorrent. The same occured there." I did also try another torrent application. Same same everywhere. –  Marvin Dickhaus Dec 15 '12 at 12:10
    
@MarvinDickhaus - Ok then we could be having one of this problems: Router or ISP might be limiting you via a port, checking packets, etc.. Try to use a torrent client with advance features like ktorrent and look for the options that are to protect you from speed limiting factors like ISP, Router, Ports, etc.. There are 2 options that are very important, DHT and "Use protocol Encryption". Do not activate to allow unecrypted protocol while you are testing. Try to download other torrent files for the test that are not on your list and give it 10 minutes time. –  Luis Alvarado Dec 15 '12 at 15:20
    
@LuisAlvarado I tunnel all traffic through an OpenVPN. So my ISP can't even do a paket inspection. If or if I'm not tunneling the traffic doesn't matter on the same machine with windows. Also I had Transmission and Ktorrent running for a long period of time with no success. –  Marvin Dickhaus Dec 15 '12 at 15:55
show 9 more comments

5 Answers

It seems the best solution to your problem is to delete the ~/Library/Application Support/Transmission/Resume folder. I've looked at a few threads and everyone seems to have arrived at that answer. To see more information, look here.

share|improve this answer
    
I don't have the Libary/-Folder in my home dir. –  Marvin Dickhaus Dec 6 '13 at 15:08
    
Try without the ~. That is likely a typo on my part. Sorry. –  Dillmo Dec 7 '13 at 0:28
    
It's neither in my home dir, nor in my root dir. –  Marvin Dickhaus Dec 8 '13 at 15:53
    
/var/lib/transmission-daemon/info/resume still i don't see that it would do any difference. –  Anders F. U. Kiær Dec 10 '13 at 21:12
add comment

Ok, easy first.

  1. Try is updating trackers and making sure your ports are open.

  2. Try manually adding the torrent (explained below). If that doesn't work disable any block lists you may have set up (risky), and lastly you could allow unencrypted seeds and stuff like that (very risky).

  3. Adding the torrent file manually. All clients have a way to add torrent, then either put in the infohash (listed on most torrent sites), or right click the Get Magnet link and copy the URL into the client.

  4. Another thing to try is updating trackers after doing all of those things.

  5. When all else fails, reinstall your torrent client.

share|improve this answer
add comment

I'd say the problem might be with the tracker itself. It might be seeing the Transmission (and other linux based clients) as leechers.

Did you try one of the big torrent clients like Vuze or uTorrent?

If that doesn't work, do you have some ports blocked on your ubuntu system that isn't blocked in Windows?

share|improve this answer
add comment

Check

Transmission->Preferences->Peers->Encryption

or

Transmission->Preferences->Peers->Blocklist

to see if you are blocking the peers.

share|improve this answer
add comment

I would encrypt transmission and enable in the connection tab the last checkbox that says something about discovering local pairs.

I will also give you my personal opinion to install Ubuntu 13.10 and not just stick to Ubuntu 12.10 as you are quite behind and transmission gets updated :)

PS: Always get the latest stable release as LTS and previous versions are for Enterprises and not Home users.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.