Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The sheet tabs in Open Office Calc appear very pixelated to me. Also the buttons to change tabs are very tiny.

Screenshot:
alt text

Is there a way to fix this appearance? All the functionality is there, but it's bugging me. Hopefully this helps some other people too.

share|improve this question
add comment

2 Answers 2

I had a similar problem, and even though the question is old, I want to provide another answer:

The sheet tabs height is defined by the width of the GTK themes scrollbar. I guess you're using Ambience, Ambience's scrollbars are a bit smaller than usual ones, so the sheet tabs get distorted.

I use a GTK theme with tiny scrollbars (Orta), so those sheet tabs were barely visible.

If you use another GTK theme, for example Clearlooks, it will look normal again. If you don't want to change your whole Desktop to another theme, you can start libreoffice/openoffice in a terminal with this command:

GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc libreoffice

Of course you can replace Clearlooks with any other theme that suits you more.

I created some launchers, so I don't have to do that every time. To do this, copy the original launchers anywhere into your home folder. They should be in /usr/share/applications/.

Make your copied launcher(s) executable by right clicking on it in a file manager and going to "properties". From there look in the "access rights" tab and click "mark as executable."

Or in the terminal, change directory to your folder and use chmod +x:

cd ~/YOURDIRECTORY
chmod +x libreoffice*

And now you have to edit each of them (right click - properties) to add the specific GTK theme to the beginning. Add env GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc in front of the command. It should look like this:

env GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc libreoffice %U
env GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc libreoffice --writer %U
env GTK2_RC_FILES=/usr/share/themes/Clearlooks/gtk-2.0/gtkrc libreoffice --calc %U
…

Copy these launchers to ~/.local/share/applications/.

Now libreoffice should look fine.

share|improve this answer
    
Excellent work, i'll give that a shot –  febs Jun 11 '11 at 2:30
    
bash -c '' has a problem: you cannot open files which have spaces in their names/in their folder's name. I found one should replace it with env! –  Meng Tian Jul 10 '11 at 13:27
add comment

Try to install / use other themes like explained here:

You need to download themes or styles for OpenOffice via Synaptic. There are several themes (styles) available, such as: default, crystal, human, tango, industrial. In Synaptic, search for "openoffice.org" and scroll down to "openoffice-style-default" or any other styles you prefer (I installed everything), and mark for installation, then you will have it.

Or if it is already downloaded then launch openoffice writer: Tool --> Options --> Under "OpenOffice.org" --> View --> Icon Size and Style

You could choose the style there. I personally prefer "default" for XP and Ubuntu. Clean interface.

Source: http://ubuntuforums.org/showthread.php?t=418842

share|improve this answer
    
Thank you very much for the answer. I can change the themes, but the only noticible difference are the icons. The sheet tabs do not change :( –  febs Jan 15 '11 at 21:35
    
I found someone with exactly the same problem as you: user.services.openoffice.org/en/forum/… . You should vote for the bug to be fixed (qa.openoffice.org/issues/showvotes.cgi?voteon=66261). –  lepe Jan 18 '11 at 1:06
1  
Good News! Changing Font size and Color of sheet tabs in Calc is going to be available in v.3.3 according to: user.services.openoffice.org/en/forum/… (which you can now test the release candidate: download.openoffice.org/all_rc.html#untested-full). Download the .deb file for your architecture (32 or 64 bits) and install with dpkg -i OOo_3.3...deb . –  lepe Jan 18 '11 at 1:36
    
Awesome news, I'll check that out, thank you! –  febs Jan 31 '11 at 1:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.