Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an all-in-one printer Epson SX130, wich I have just tried to install. I got the printer working with no problem, but I couldn't set the scanner up. I have had another all-in-one printer before (Brother DCP-125C), and had just the same problem, so I decided to try the same trick I used to do then, running the scanning program as super-user:

$sudo simple-scan

and

$ sudo xsane

Once again, it worked just fine, and I could use the scanner.

Anyhow, this solution is a little annoying, because I also have to change the permissions to the files I get scanning like this.

I have been searching the internet for solutions and got to know this must have something to do with user groups permissions, but couldn't find a satisfying solution. Is there anyone with an idea?

Thank you in advance.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You need to be a member of the 'scanner' group. In a terminal, type sudo adduser <yourusernamehere> scanner. Replace <yourusernamehere> with your username, without the angle brackets.

share|improve this answer
    
It works!!! Thank you! :-) –  Eugénio Outeiro Nov 3 '12 at 17:36
    
You're welcome. –  Clive van Hilten Nov 3 '12 at 18:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.