Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu precise and have the following external hard disk:

$ sudo blkid | grep Elements
/dev/sdb1: LABEL="Elements" UUID="e6daad35-1f57-4281-8683-a03c20cfc5a3" TYPE="ext4" 

My etc/fstab has this line at the end:

$ sudo cat /etc/fstab | tail -1
UUID=e6daad35-1f57-4281-8683-a03c20cfc5a3 /media/Elements ext4 defaults,uid=1000,gid=1000,umask=007 0 2

Yet, when the system boots I get a message "an error occurred while mounting /media/Elements". Once I am in, a simple mount from the console succeeds:

sudo mount /dev/sdb1 /media/Elements/

What's wrong with my setup that doesn't allow Ubuntu to mount the external drive automatically at boot time?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I think that for ext4 filesystems the uid and gid options are not allowed.

I tried to mount such a type of filesystem from command line giving -o uid=1000 and it gave me an error, and working without.

share|improve this answer
    
removing the uid and gid options from /etc/fstab did the trick. –  Marcus Junius Brutus Nov 4 '12 at 18:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.