Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to upgrade my Ubuntu 11.01 to 12.04 using update manager, at almost the end of the upgrading process, I was prompted to keep or remove unnecessary files so I removed them. But now, when restarting the computer, it brings up a window with "GNU GRUB version 1.99-21ubuntu3.4" with four options to start like "Ubuntu, with LInux 3.0.0-26- generic" . . . but all of them do not start the computer and instead I have this

error: no such partitions.
error: no such partitions.
error: no such partitions.
Press any key to continue . . . 

When pressing any key, it just goes back to the first screen.

What I did try:

I tried to use Ubuntu live CD to start the computer didn't workout.But I used Slacko Puppy live CD and I was able to get in to my computer.

I tried Boot-repair live cd, but somehow my laptop is not booting from this particular CD

I have the feeling that, I probably messed up (removed GRUB files).

My question:

How do I fix this issue by using Slacko Puppy live CD since it somehow seems the only way my computer is responding to?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.