Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to Ubuntu/Linux.

I have installed the Ubuntu 12.10 version on Windows 8. After installation, there is no wireless connectivity. I have searched the forums and tried things that have worked for others. But, every way seems to be a dead-end to me.

I ran the command lspci -nn | grep 0280 and here is the details I get.

03:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]

The command sudo iwconfig gives the below output.

eth0      no wireless extensions.
lo        no wireless extensions.

I downloaded the bcmwl-kernel-source from Ubuntu Software Center and installed, but there is no change.

I am at a loss, being new to the OS.

Any help from you will be much appreciated. Kindly let me know if I missed to provide any information.

share|improve this question

If you have several drivers installed, the Linux kernel will pick the right one automatically. Regardless of the driver, though, your chip might need firmware to work. Find firmware-b43-installer from the Software Center.

share|improve this answer

The STA driver, provided by bcmwl-kernel-source is correct for your device.

Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]

What is the result if you load the module? Are there warnings or errors?

    sudo modprobe wl
    dmesg | grep wl
share|improve this answer

Install synaptic form the Ubuntu Software Center

In Synaptic select bcmwl-kernel-source and bcmwl-sta-source

Then install it.

I'm sorry you must have a connection internet try wired.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.