Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While trying to install open mpi on my Ubuntu 12.04, I am getting error unable to locate package libopenmpi-dev. What to do?

$ sudo apt-get install libopenmpi-dev openmpi-bin openmpi-doc
unable to locate package libopenmpi-dev
unable to locate package openmpi-bin
unable to locate package openmpi-doc
share|improve this question
up vote 1 down vote accepted

Try to run apt-get update before you install the openmpi package.

Also you can use the following command to search all openmpi related package, for example:

apt-cache search openmpi

If it still doesn't work, try to use a different mirror, below is GUI and easier:

sudo software-properties-gtk



The package is definitely in the official repository (12.04):

As mentioned earlier, please run apt-get update and then apt-cache search for the libopenmpi packages.

If it still doesn't help. Try to change your mirror. Or paste the content of your /etc/apt/sources.list

share|improve this answer
Thanks Jokerdino for your suggestion but apt-cache search openmpi not giving any result .Is that possible that libopenmpi is not available for Ubuntu 12.04 ?because it was working fine on my Ubuntu 10.10. – dnivog Nov 3 '12 at 18:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.