Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux and was hoping someone can help me get Shogun 2 up and running in Steam which was downloaded via PlayonLinux. Currently, the game installs and shows a license screen briefly before it shuts down with no error message.

In the System Info tab, Steam does not seem to detect my video card though the nVidia drivers have been installed and my computer recognizes the card (GeForce GT610). Maybe there is another issue though. Any help would be most appreciated! if useful, I have an ASUS M5A97 motherboard and running Ubuntu 12.04,

The system info Steam shows follows:

Processor Information: Vendor: AuthenticAMD Speed: 4200 Mhz 4 logical processors 1 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Supported SSE42: Unsupported

Network Information: Network Speed:

Operating System Version: Windows XP (32 bit) Wine version: wine-1.4.1 NTFS: Supported Crypto Provider Codes: Supported 323 0x0 0x0 0x0

Video Card: Driver Not Detected

DirectX Driver Name:  nv4_disp.dll
Driver Version Not Detected
DirectX Driver Version:  6.15.12.6658
Driver Date Not Detected
DirectX Card: NVIDIA GeForce 8300 GS
VendorID:  0x10de
DeviceID:  0x423
Number of Monitors:  1
Number of Logical Video Cards:  1
No SLI or Crossfire Detected
Primary Display Resolution:  1440 x 900
Desktop Resolution: 1440 x 900
Primary Display Size: 15.00" x 9.37"  (17.68" diag)
                                        38.1cm x 23.8cm  (44.9cm diag)
Primary Bus Type Not Detected
Primary VRAM Not Detected
Supported MSAA Modes:  2x 3x 4x 5x 6x 7x 8x 9x 10x 11x 12x 13x 14x 15x 16x 

Sound card: Audio device:

Memory: RAM: 7933 Mb

Miscellaneous: UI Language: English Microphone: Not set Media Type: CD-Rom Total Hard Disk Space Available: 1861779 Mb Largest Free Hard Disk Block: 720019 Mb OS Install Date: May 08 2010 Game Controller: None detected

Installed software: Adobe Flash Player 11 Plugin Microsoft Visual C++ 2005 Redistributable Microsoft Visual C++ 2008 Redistributable - x86 9.0.21022 Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17 Sid Meier's Civilization V Steam The Witcher: Enhanced Edition Total War: SHOGUN 2 Wine Gecko (32-bit)

share|improve this question

2 Answers 2

I will start my answer saying, I maybe wrong. But, I looked at your Device ID in PCI database. But, There's no card for 0x423. But 8300 GS's ID is 0x0423. So, I think this is a counterfeit card. Please install this card under Windows with a Driver Downloaded on NVIDIA's official site. If the offcial driver (download from nVidia site only) can be detected with your your card, you are safe. (don't use drivers that came with your card.) I know this because it happened to me. Most counterfeit cards use fake IDs that close to actual card. (in this case 8300 GS, not 610GT)

Maybe I'm wrong.

share|improve this answer
    
Thanks for your answer. I hadn't noticed that. I don't think it's the problem though because I got the nVidia driver version 304.43 directly from the website and my computer recognizes the card as a GT 610 - Only Steam is showing the version as 8300 GS. Is there a way to trick Steam into recognizing the correct drivers or should I try reactivating them? Would uninstalling Steam work? And if so, is there a way to do that without having to download all the games again? Thanks! –  user104134 Nov 3 '12 at 16:59
    
I don't use steam, so I can't answer about steam. But linux nvidia driver detects counterfeit cards. Only windows driver can't recognize them. –  vishwaje Nov 9 '12 at 12:15

Why need to use Steam on Wine? They now have Steam for Ubuntu, which you can easily install with an apt-get command or ubuntu software centre. You should be able to install the .deb file for beta here. This will work on your machine much better than running an exe on wine.

share|improve this answer
    
on a side note, you can add the linux driver for your nvidia card by going into settings > drivers and it should prompt you about using a proprietary driver on your system. Install the according deb accordingly, this may be a short way out of your problem. –  sharksfan98 Dec 31 '12 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.