Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded a server to Ubuntu 12.04 with a fresh install and my NTFS partitions won't mount as user at boot but I can mount them as user manually from the console with $ sudo mount -a. Using ntfsfix reports no problems and chkdisk sees nothing wrong under Windows 7. Are the drives not ready to be mounted at boot and default to root instead of user for some reason?

Here is my /etc/fstab:

UUID=E4E6B30CE6B2DDCC  /media/Bowles        ntfs-3g defaults,uid=1000,gid=1000,umask=022  0  0
UUID=A040C42340C3FDD2  /media/Burroughs     ntfs-3g defaults,uid=1000,gid=1000,umask=022  0  0
UUID=EA022C73022C46C3  /media/DoctorGonzo   ntfs-3g defaults,uid=1000,gid=1000,umask=022  0  0
UUID=BA425A384259FA19  /media/Geist         ntfs-3g defaults,uid=1000,gid=1000,umask=022  0  0
UUID=E87CFAE57CFAAE06  /media/DouglasAdams  ntfs-3g defaults,uid=1000,gid=1000,umask=022  0  0

Here is the output of ls -l after boot:

drwxr-xr-x 1 xbmc xbmc   4096 Oct 31 21:46 Bowles
drwxrwxr-x 1 root users  8192 Oct 31 21:46 Burroughs
drwxrwxr-x 1 root users  4096 Oct 28 21:45 DoctorGonzo
drwxrwxr-x 1 root users 12288 Oct 31 19:56 DouglasAdams
drwxrwxr-x 1 root users  4096 Nov  3 01:03 Geist

If I unmount and mount again with $ sudo mount -a from console, the output of ls -l:

drwxr-xr-x 1 xbmc xbmc  4096 Oct 31 21:46 Bowles
drwxr-xr-x 1 xbmc xbmc  8192 Oct 31 21:46 Burroughs
drwxr-xr-x 1 xbmc xbmc  4096 Oct 28 21:45 DoctorGonzo
drwxr-xr-x 1 xbmc xbmc 12288 Oct 31 19:56 DouglasAdams
drwxr-xr-x 1 xbmc xbmc  4096 Nov  3 01:03 Geist

Update

I was fooling myself, I had a custom udev rule set up to auto-mount file systems by label for USB drives, borrowed from here, but didn't update the rule to accommodate for my additional hard drives. Updating the rule to auto-mount only drives after /dev/sde solved my problem. Thank you again for your reply cartoonist.

share|improve this question
add comment

1 Answer 1

This may help. Mount your ntfs partition with these options: rw,nosuid,nodev,allow_other,default_permissions

For example in /etc/fstab

UUID=E4E6B30CE6B2DDCC  /media/Bowles  ntfs-3g rw,nosuid,nodev,allow_other,default_permissions,umask=022  0  0
share|improve this answer
    
Thank you for the reply, but unfortunately it didn't work. I'm wondering if my set up has something to do with it. The first NTFS ,'/media/Bowles' is a partition on my boot drive, while the three other NTFS file systems are separate hard drives. I think that's why the first mounts as it should while the others don't. Is there a way to delay mounting of the other filesystems in '/etc/fstab'? Or, could I mount from '/etc/rc.local' post boot? –  aCanuck Nov 3 '12 at 13:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.