Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Long story short, I tried installing something via apt-get install and accidentally terminated the process through terminal. I now can't use apt-get install, Ubuntu Software Center, etc. I tried running sudo apt-get clean and sudo apt-get autoclean, but to no avail.

I then tried running sudo apt-get install -f, and got the following results:

    Do you want to continue [Y/n]? y
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database ... 216122 files and directories currently installed.)
Preparing to replace libc6 2.15-0ubuntu10.2 (using .../libc6_2.15-0ubuntu10.3_i386.deb) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb (--unpack): subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I fix this error, or at least "reset" apt-get so I can install things again?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Just reboot the machine. Whatever is using that file should no longer be using it after a reboot. Then run sudo apt-get install -f to repair it. That should work for ya.

share|improve this answer
    
Thank you so much! I had rebooted the machine but I forgot to run install -f afterwards. –  Archio Nov 3 '12 at 2:11
tareq@tareq-pc:~$ sudo apt-get install -f
[sudo] password for tareq: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 kaffeine:i386 : Depends: kdelibs4c2a:i386 (>= 4:3.5.9) but it is not installable
                 Depends: libqt3-mt:i386 (>= 3:3.3.8-b) but it is not installed
                 Depends: libxine1:i386 (>= 1.1.8) but it is not installed
                 Depends: libxine1-x:i386 but it is not installed
                 Depends: hdparm:i386 but it is not installed
                 Depends: python-qt4:i386 but it is not installed
                 Depends: python-apt:i386 but it is not installed
                 Recommends: kdebase-runtime:i386 but it is not installable
                 Recommends: install-package:i386 but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

didn't work for me, please help!.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.