Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

So I got to installing Ubuntu 12.10 on a SONY VAIO desktop (a Sony VAIO RS420) but it runs terribly slow. The windows load slow (it won't even pull up Terminal, but connects to WiFi and opens Firefox) but the computer itself seems to run fine (like when downloading files or moving files it works BETTER than Windows 7). I did get an error about needed to update a language pack, but that's it. What can I do to make this thing work correctly? Downgrade Unity or GNOME ? Any help is appreciated.

share|improve this question
    
I also added another 512MB RAM to the system, there is a total of 1024MB now, so that should be enough I would think... –  UncleNerdicus Nov 3 '12 at 1:20
    
1 Gb of Ram is a bit low in my opinion for Ubuntu 12.10. I would try Lubuntu or Xubuntu. You may try installing xubuntu-desktop or lubuntu-desktop on your system and check if there is a significant improvement. –  To Do Feb 4 '13 at 15:58
    
Xubuntu rocks - I find it very quick and better for how I use my computer. –  Scott Goodgame Mar 25 '13 at 17:04
add comment

marked as duplicate by Luis Alvarado Mar 25 '13 at 17:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

The cause of your problem is likely due to slow 3D graphics acceleration. Unity 2D has been removed from Ubuntu 12.10 and the default desktop is now Unity 3D.

You have two options:

  1. Try sudo apt-get install llvm-dev for graphics acceleration on Ubuntu 12.10

    This package uses the CPU, as opposed to the GPU for 3D graphics rendering, which may speed up your machine if you have a fast / new processor or PC, but may also add yet another bottleneck to your system if your CPU is slower than your graphics card).

  2. If that doesn't speed up your machine, you have two (further) options:

    1. Downgrade to 12.04 and run it in Unity 2D mode.

    2. Install a low-resource desktop environment, for example LXDE (used in Lubuntu) or XFCE (used in Xubuntu). You can also use MATE - a fork of the old GNOME 2.x project

Here's how you can install these desktop environments:

Lubuntu

sudo apt-get update && sudo apt-get install lubuntu-desktop

Xubuntu

sudo apt-get update && sudo apt-get install xubuntu-desktop

Mate

$ sudo -i # or su -
# add-apt-repository "deb http://packages.mate-desktop.org/repo/ubuntu quantal main"
# apt-get update
# apt-get install mate-archive-keyring
# apt-get update
# apt-get install mate-core
# apt-get install mate-desktop-environment
share|improve this answer
add comment

Most likely Unity (the desktop environment Ubuntu uses by default) emulates OpenGL in software because your graphics driver doesn't support hardware OpenGL well enough.

Depending on your hardware it may be possible to use another graphics driver (see How do I install extra drivers? for how to install additional drivers) or to tune your existing driver to provide better OpenGL support. For that you should ask a new question that includes the output of

sudo lshw -C video

and

/usr/lib/nux/unity_support_test -p

on the command line.

Or you could try another if desktop environment like Gnome classic, Gnome Shell, Xubuntu, ... works better for you.

share|improve this answer
    
That would make sense.. If I am not mistaken its a NVIDIA graphic card from 2002. Thats the problem.. the command line WON'T load.. oh boy... –  UncleNerdicus Nov 3 '12 at 3:14
    
What I am noticing is this- the think works perfectly fine (the login screen) until I get to the desktop with the Unity left dock bar and top bar. then the thing freezes.. I can't pull up Terminal for crying out loud.. lol –  UncleNerdicus Nov 3 '12 at 3:34
    
Well, was able to pull up Terminal in recovery mode.. it is a Radeon 9200 –  UncleNerdicus Nov 3 '12 at 4:08
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.