Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Although it's an abundantly treated matter, I'm unable to find an answer valid for my needs. I had a 12.04 installation of ubuntu and I decided to install the 12.10.

I copied (using GParted) the partition where my system was to an external hd where there is a windows partition. Then I installed the newest ubuntu version and now I want to take back some files (for example my .emacs) from that partition but when I try to mount it, it is not found as sdb and if I mount it from /dev/usb/hddev0 I don't get any output, only a blinking cursor, no errors, no output. I even tried to mount it as an ntfs disk but the result was the same. It's like the hd cannot be detected.

So how can I access data to that disk? Could I get them from GParted terminal instead of Ubuntu one?


share|improve this question

I found this in another post. In a "Terminal", try entering:

sudo mkdir /media/${USER}

If you have other users on the same machine, say, fred, create /media/fred as well

Amazing that such a basic issue was not addressed before 12.10 was released!

share|improve this answer
In the end I managed to mount my external drive. I used a gparted live cd, booted from cd and from the gparted terminal (which, basically, is a linux terminal) I run sudo mount /dev/myexthd /media. All was OK and I was able to recover my precious .emacs :-). BTW thanks for your reply! – Luigi Tiburzi Nov 8 '12 at 20:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.