Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There are many questions about resolution issues on askubuntu but no question/solution seems to solve my issue.

I've a 12.04/precise host system and installed Ubuntu 12.04/precise as guest system as well. After installation I had the option of selecting 1024x768 (4:3) and 800x600 (4:3) as resolution in display settings. After installing guest additions the options 1280x960 (4:3) and 1440x1050 (4:3) was added to the list. Now 4 in total all having the 4:3 ratio.

I then activated full screen mode (host+f) and got the guest running in native 1920x1200 (16:10) for my screen. After deactivating full screen two more options had been added to the resolutions dropdown list, 1920x1200 (16:10) and 1600x1200 (4:3).

I want to run the guest in 1920x1080 (16:9) so I can easily record screencasts in "full-hd". Last time I had this problem the solution was to run "VBoxManage controlvm nameofyourVM setvideomodehint width height colordepth" command from the host but now I want to know if there is any easier way to solve this?

share|improve this question

Just install Virtualbox Guests Additions but before be sure you have DKMS in terminal:

sudo apt-get install dkms

and update:

sudo apt-get update

sudo apt-get upgrade

after this install guests additons,restart pc and you got the right screen ratio.

share|improve this answer
I'm afraid that didn't help me. As I said in the first post Guest additions are already installed. – CHolmstedt Nov 6 '12 at 6:37
In my case, I upgraded VirtualBox then upgraded Ubuntu, and somewhere along the line the guest additions seemed to stop working (the screen wasn't resizing). I reinstalled the guest addditions which upgraded them to the latest version, rebooted the guest VM, and everything started working again (could change the VM resolution). – jfritz42 Nov 12 '12 at 18:17

Go To the 'File' menu, and activate 'Environment setting (P)'. Select 'Display', and change the setting for 'Maximum guest screen size' to 'hint', which allows you to set an arbitrary size for both width and height (eg., 1920 and 1200).

Reboot the virtual machine and enjoy it.

share|improve this answer
Which file menu are you talking about? – CHolmstedt Mar 10 '15 at 17:42
@CHolmstedt The file menu of the Virtualbox Manager works. – Marcel May 13 at 19:07

I know there has benn a long time since last activity in this thread but this helped me and is thanks to you. In my case the tools where already installed.

  1. install dkms
  2. enter full-screen mode
  3. uninstall the tools
  4. reboot
  5. install the tools again
share|improve this answer

This is based on the answer of @Sangsoo Kim which works well for me:

  1. Go to "File" > "Preferences"
  2. Go to "Display"
  3. Change "Maximum Guest Screen Size" to "Hint"
  4. Enter 1902 x 1200 as Width and Height.
  5. Restart the virtual machine and voila! it just shows the right resolution.

Hope this help!

share|improve this answer

I too had the same issue. I installed dkms and then installed the Linux headers as per @Daniel answer. Then rebooted Ubuntu while remaining in full screen mode and it switched straight to the correct 16:9 resolution.

share|improve this answer
  1. Install VirtualBox tools
    Check before this manual

  2. Reboot.
share|improve this answer

I had the same issue, but now it works. I had to install:

sudo apt-get install linux-headers-`uname -r`

The error was logged in: /var/log/vboxadd-install.log

share|improve this answer
Thanks for the response. I will try that. – CHolmstedt Jul 5 '13 at 17:06
@CHolmstedt So did it work? – Daniel Oct 26 '13 at 7:01
@Daniel No, I'm afraid not. I have not found any solution that works for my problem yet. – CHolmstedt Oct 27 '13 at 7:45

I had the same issue, i installed fresh ubuntu, then updated all packages + dkms, then rebooted in fullscreen. Installed the Guest Additions while being in fullscreen mode, and rebooting in fullscreen...

This fixed it for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.