Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dell M4600 with NVidia Quattro K2000m. After first installing Ubuntu it showed 2 experimental drives in "Additional drivers". After reboot, they were gone. And I don't have any xorg.conf. It doesn't exist. And Ubuntu can't recognize the graphics card. It says "unknown".

External monitor works through VGA, but not HDMI or display-port.

Any ideas on what's wrong and what to do?

share|improve this question

2 Answers 2

Now i've deactivaded optimus and the drivers showed up. The first disabled the vga-port so I tried the other one on the list. It worked and I got vga-port active again. No displayport though. So I'm pretty much back to where i started, but with better 3D-performance I guess

share|improve this answer

There isn't an /etc/X11/xorg.conf because Ubuntu doesn't put it there, anymore (it seems this was a change that has been in place for a few versions now).

This previous question mentions that Optimus is interfering. Chances are, that's your problem, too. Assuming that's the case, you have two options:

  1. Install Bumblebee The Bumblebee project brings Optimus support to Linux. This is the recommended path, at least to try first, especially if you want to be mobile with your computer (Optimus is a graphic switching utility that essentially "clocks down" your graphics card in order to conserve battery). Installing it is pretty easy, simply run sudo add-apt-repository ppa:bumblebee/stable and update apt with sudo apt-get update. Then run sudo apt-get install bumblebee bumblebee-nvidia. You may need to enable the nVidia drivers again from "Additional Drivers" (I don't know for sure, as I haven't used it, personally), but after that you should be good to go.

  2. Disable Optimus If you can't get Bumblebee working, or don't care about the power management that Optimus provides, then you can disable Optimus. For this, you'll need to enter your computer's BIOS. For Dells, the key to press during boot (at the Dell splash screen, before Ubuntu starts loading) is usually F12. Once your in your BIOS settings, look for an entry named "Optimus" and disable it. Save and exit, then boot into Ubuntu and you should be able to enable the nVidia drivers (if Ubuntu doesn't do it for you).

share|improve this answer
    
I did try to install bumblebee but that didn't do any differense. Still no drivers, no displayport and no regognicing the nvidiacard. I'm at work now, but I'll disable optimus when I get home and see if It'll work to get the drivers. (The drivers are installed when I check synaptic) –  Askal Nov 2 '12 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.