Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my work I need to study about FOSSology. This tool supports only in Linux. So i have installed Ubuntu version 12.10 Quantal. Through net i have come to know Ubuntu has inbuilt postgreSQL application. But when i installed i don't know how to see whether it is already installed. Could you please help me in solving this issue. It's high priority and i have short time to finish my work.

I have downloaded manually and while install after executing this command sudo dpkg -i File.dep i am getting error message saying that This need root user privileges. PLease help me.

share|improve this question

2 Answers 2

The following command when run from the terminal will tell you:

dpkg -l postgresql

If it shows:

No packages found matching postgresql.

this means it isn't installed. You can install it with:

sudo apt-get install postgresql

It will ask you for your password and then download, install and configure postgresql.

share|improve this answer

When you try to install, you need root privileges. However, you should use the built-in apt. Run:

sudo apt-get install postgresql

If it is already installed, it will tell you and gracefully fail. When it finishes, or says it is already installed, you have PostgreSQL.

If you really need to use the existing .deb file(this is not recommended), use:

sudo dpkg -i file.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.