Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I met a problem while installing Ubuntu on my Nexus7 in a Virtual Box VM. Although the tablet was unlocked and successfully loaded with fastboot method, installation stuck while erasing data. Why would it happen?

share|improve this question
1  
What on this earth are you saying? You tried installing ubuntu on nexus 7 using a Virtual Box VM. I'd offer all my reputation as bounty to someone who can answer this question satisfactorily. –  nikhil Nov 2 '12 at 17:03
1  
If you are running Ubuntu under Virtual Box, you may not be able to successfully 'write' to Nexus 7. You really need native control of the USB port. The installer would take some time to 'download' the images (from Internet) - but would then stall, just after (or before ?) it asks for your sudo password. Please add more details to your question. –  david6 Nov 2 '12 at 21:37
1  
Yes, i am running Ubuntu under Virtual Box and try to install Ubuntu on my nexus 7, everything is ok the images of Ubuntu was downloaded also, the tablet also can be linked PC via fastboot method; but when i run Ubuntu installer on PC, it doesn't work on the step of earsing data before write to nexus 7. –  user103960 Nov 3 '12 at 14:47
    
can you tell me what is the –  user103960 Nov 3 '12 at 14:54
2  
Did you check for connectivity, as suggested (below) by @mfisch? –  david6 Nov 9 '12 at 21:42

2 Answers 2

Try running fastboot devices from the command-line, if it doesn't show any devices, then it won't work. I seriously doubt you can install it from a VM. You could try using an Ubuntu live-cd on you system though.

share|improve this answer

I was able to succesfully install Ubuntu to my Nexus7 using a VM of Ubuntu in Windows7.

I used the Nexus7 toolkit to ensure I had the correct drivers, I unlocked via windows and then installed via Ubuntu. I had no issues getting this setup and working using the ubuntu-nexus7-installer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.