Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to send a file from my Samsung Galaxy Nexus phone to my Ubuntu 12.10 PC, I get a message on the phone reading "connection unsuccessful". What might be the cause of this?

The devices are paired and I can succesfully send files from the PC to the phone.

share|improve this question
    
Maybe you need to compress the file to send. Works fine with me –  Charleston Jul 7 at 14:54

7 Answers 7

up vote 13 down vote accepted

Install Blueman Bluetooth Manager from the software centre.

Works much better than the default bluetooth manager, I had the same issue as you with the default manager.

share|improve this answer
    
Thanks a lot, that solved several issues I had with Bluetooth. A bit disappointing that it doesn't work out of the box, though. (I mean, why not, when the solution is known anyway?) –  afeder Nov 2 '12 at 16:09
    
Great software, but I have a very rare issue. I am able to pair devices, I paired my Android with my laptop, I'm able to explore the files via FTP with both native and blueman controllers, I'm able actually to play music from Phone to PC via bluetooth using blueman, but I'm not able to send a single file (a png photo) via bluetooth. It crashes with both controllers. Any idea? –  unmultimedio Feb 17 at 6:03

Search and find "Personal File Sharing" in the dash and activate both the checkboxes under "Recieve Files over Bluetooth". In this way you won't have to install 'blueman'.

share|improve this answer
    
"Go to Personal File Sharing" Where is this? –  Catskul Feb 2 '13 at 17:03
3  
If you are unable to find it in a menu or using the 'dash', open a terminal window, and type "gnome-file-share-properties" followed by pressing enter. –  Mark Apr 19 '13 at 14:02
1  
Or, instead of opening terminal, just press Ctrl+F2 and type "gnome-file-share-properties", then press Enter :) –  m4tx Jun 5 '13 at 17:47
    
This worked for me! Still not able to browse phone's folders but at least I can send from the phone to computer... I don't know why people keep recommending to install Blueman, it seems to me that is only an applet and it hasn't solved any of my bluetooth problems so far. –  Christian Vielma Sep 12 '13 at 16:22

I decided to install blueman. Then it worked. Later, I removed blueman and it still works.

share|improve this answer

Blueman seems nice, but all it did was reveal the error when transferring a file ("Connection refused"). After a bit of fiddling, what did the trick was unpairing my phone from my laptop and pairing them again.

Apparently, something in the previous pairing was set up incorrectly, although I've no idea what. :|

share|improve this answer

i config it through the dconf

make a search using ctrl+f and type in dialog box bluetooth and enable the options that it list to you.

restart you PC and it work!!!

my laptop was with the same problem but it solve bluetooth problem!!!

i hope that solve you problem!!! Greetings!!!

share|improve this answer
    
the first option bluetooth-accept-files you must edit this value and type always, to receive files always :) sorry i don't put this details before !!!! –  user135537 Mar 15 '13 at 14:43
    
You can edit your answer to add that information. –  Eric Carvalho Mar 15 '13 at 14:54
    
Valeus, kkk :)!!! –  user135537 Mar 22 '13 at 19:03

Easiest way is to browse the apps for "Personal File Sharing" and select Receive files in Downloads folder over bluetooth. This will enable to send files/photos from your Andriod phone to Ubuntu. It worked for my xperia SL

share|improve this answer

0 down vote

Use rfkill to ensure there isn't any hard/soft block on your bluetooth device. Issue:

rfkill list

If block is there, use the unblock option to unblock it:

rfkill unblock wlan1

Replace wlan1 with the type for your bluetooth device.

Refer http://wireless.kernel.org/en/users/Documentation/rfkill

share|improve this answer

protected by Braiam Sep 20 at 20:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.