Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.10 32 bits, fresh installation.

How can I make Unity maximize or minimize a window?

I see no button,option, anything, do I miss something big? Quick googling did not give me a piece of answer, too:

First screenshot

Second screenshot

On first screen, I have a terminal window. Only clue about maximizing it I found was pressing F11 which made it fullscreen, hiding left bar as well. I would prefer it to take whole free space instead of whole screen. How can I do that?

On second screen, I have an opera browser which takes bigger part of the screen but I can't make it take whole screen. Restarting opera did not work.

How do I minimize/maximize apps? Also, in case I would like to see the desktop, only solution I found was closing everything

Help guys. I kind of like new GUI, but I can't have simplest tasks done there, I feel like I miss something big there.

share|improve this question
    
Have you tried to right click on the app to see if there is an option? –  Hai Vu Nov 2 '12 at 13:51
    
Hey, thanks for quick reply. Where should I click in both cases? When I click on the terminal normal terminal options appear (open terminal, open tab, close window, profiles etc), in case of opera browser normal opera context menu appears (depending on what you click) –  omg_scout Nov 2 '12 at 13:56
1  
It looks like right-click does not do it. Have you tried to move your mouse to the top of the screen? The menu options should appear, try the Windows menu. –  Hai Vu Nov 2 '12 at 14:03
    
@HaiVu there is no "Windows" menu, link provided: imageshack.us/a/img515/615/screenshotfrom201211021.png (there is a view menu, with full screen option, but it works like mentioned F11). Oh, and in the opera browser nothing happend when I hoover mouse pointer on the top. It stays as in the first screenshot. –  omg_scout Nov 2 '12 at 14:08

3 Answers 3

up vote 1 down vote accepted

Seems like you have a problem with the window manager.

Did you change any of the settings of Compiz? used compizconfig?

First, try the following command from the terminal (ctrl+alt+t): "metacity --replace &". Does now you have a bar at the top of the windows?

The next thing is to try to load compiz window manager again (3D windows manager): "compiz --replace &".

If after the second command you don't have a bar again, i suggest you to reset compiz settings. you can try "unity --reset"

share|improve this answer
    
I did not touch anything in Compiz. Trying metacity -replace & returns that no metacity installed. compiz -replace & helped, thank you! Marking your answer as accepted –  omg_scout Nov 2 '12 at 14:29
    
I just installed Ubuntu 12.10 about an hour ago, so this is a pristine system. I did not touch Compiz either. –  Hai Vu Nov 2 '12 at 14:30
    
Oh, @idgar, do you know why were there invisible before? Is it normal unity behavior? –  omg_scout Nov 2 '12 at 14:32
    
about Metacity - makes sense, didn't think about it but starting from 12.10, there is no 2D window manager. guess I still have it because I've upgraded from 12.04. about Compiz & Unity, not normal Unity behavior that's for sure but Unity is a desktop environment which underlying Compiz window manager, and for some reason Compiz sometimes is a little bit complicated. can't explain why by most of times when I had a problem, those commands helped me. –  idgar Nov 2 '12 at 14:39

in compizconfig manager try to enable window decoration.

share|improve this answer
    
U iz a star!!!! –  fleamour Mar 23 at 11:55

It seems you can press F11 to toggle full screen on most apps. Also, you can move your mouse to the top of the screen, where a menu for that app will appear. Choose View > Full Screen.

Update

Opera is weird: it does not show the menu, but if you click on the "Opera" icon at the top left corner, it will drop down a menu, choose "Show Menu Bar" and you have more control. I found that if I turn on show the menu bar, then turn off, the window will go to full screen.

share|improve this answer
1  
Hey, F11 makes applications takes full screen (hiding unity topbar and the launcher bar on the left) Is it possible to make apps take whole free space? (leaving launcher bar and unity topbar - the one with clock etc)? Also moving mouse on top of the screen does not allow to maximize/minimize for me, could you post the screenshot of such menu? –  omg_scout Nov 2 '12 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.