Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Clicking Suspend button from top right corner menu in Gnome desktop environment, does nothing. I have Alternative Status Menu extension enabled through Tweak Tools but it seems ineffective. Is there a work-around?

share|improve this question
sorry but this solution doesn't work, instead no more option has added at power-managment menu on settings menu. I trining to looking up and testing deb app to resolve this problem.. – user142401 Mar 21 '13 at 22:56

It's a known bug. Looks like update is on the way. See this bug on launchpad.

share|improve this answer

The latest Gnome Shell includes a fix.

Ubuntu's repository is outdated, so add the Gnome repository, and run updates.

$ sudo add-apt-repository ppa:gnome3-team/gnome3
$ sudo apt-get update

Then open the update manager and install the updates. This should fix the suspend option.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.