Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to setup the wake-on-lan, the two PCs are connected through a switch.

Here is the configuration of the eth0, in the BIOS I couldn't find any information regarding the wake-on-lan.

Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
                                         1000baseT/Full 
    Link partner advertised pause frame use: Symmetric
    Link partner advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: yes

After I shut down the PC, I used different tools to send out the magic package, but nothing happens. Any suggestion?

share|improve this question

2 Answers 2

up vote 9 down vote accepted

Your card is supported, now to configure wake-on-lan:

  1. Install ethtool

    sudo apt-get install ethtool
    
  2. Edit /etc/rc.local to add this line before the exit 0 line:

    ethtool -s eth0 wol g
    
  3. Find out the MAC address of your network card (replace eth if with your interface name, eth0, eth1, ..):

    ifconfig eth | grep "HWaddr" | awk '{print $5}'
    
  4. Shutdown the machine. You should be able to wake it up using:

    wakeonlan your_mac
    
share|improve this answer
    
I tried this, and I'm receiving the following address. Sending magic packet to 255.255.255.255:9 with 4c:02:89:00:xx:xx send : Network is unreachable at /usr/bin/wakeonlan line 126.. But I'm connected to the network through a switch, I also can ping the UPS network card. What can be the problem? –  run Nov 2 '12 at 10:30
    
try this one: wakeonlan -i 192.168.0.255 mac. Where you might have to replace 192.168 to reflect your network. –  rosch Nov 2 '12 at 14:08
    
Also make sure your network card really is in standby mode: there should be a green or yellow LED light. –  rosch Nov 2 '12 at 14:19
    
Did you succeed? –  rosch Nov 6 '12 at 22:50
    
I can't test now, because the PC is not in the office –  run Nov 7 '12 at 10:37

You need to install ethtool by typing with root privilage:

apt-get install ethtool

Next step is to enable wake on lan in your system by typing:

ethtool -s eth0 wol g

I describe such scenario and few optional next step on my blog

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.