Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have setup u VPN connection to our Windows 2008 server at the office and it seems to work fine.

For some reason, however, I still am not able to access the network shares over a VPN connection using my standard fstab entries. When I am physically connected to the network, it works fine, but now when trying this over VPN I get the following error:

mount error(110): Connection timed out
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

My /etc/fstab looks like this:

//server2008/share    /mnt/share    cifs    iocharset=utf8,credentials=/home/aron/.smbcredentials,uid=1000  0       0

As said, it works fine when physically connected, but over VPN it just wont work.

Any help is appreciated.

EDIT:

It seems the Windows firewall is making things harder on me. When I turn it off, I get a bit further, although I still get the following error message:

Unable to find suitable address.

The strange thing is that I have file sharing added as an exception to the firewall. Port 137-139 and port 445 are open, which should suffice, shouldn't it?

EDIT Jan 20th:

Still not working. When I have the firewall turned on, it times out. When I turn it off, I get the not suitable address error. Turning the firewall off is not an option, by the way.

share|improve this question
    
Once you enter the realm of VPN all traditional sentiments of what should be sufficient go out the window. –  Marco Ceppi Jan 13 '11 at 17:30
add comment

3 Answers 3

Try to add .domain to your server. i.e. //server2008.vpndomain.local/share. Use domain of your remote VPN server instead vpndomain.local

share|improve this answer
add comment

You need a way to resolve the server name. When you are connected locally this can be done with the cifs broadcast name resolution service, but this does not work over a vpn or other routed connection. If the host name can not be resolved by your DNS server then you either need to use the IP address in your fstab, or add an entry to /etc/hosts.

share|improve this answer
    
Thanks for the reply. I actually have a hosts entry for the server setup and pinging works just fine. –  Aron Rotteveel Jan 12 '11 at 8:00
add comment
up vote 0 down vote accepted

I was finally able to solve this problem; I believe it was caused by an IP conflict.

Both my home network range as my office range used the 192.168.1.0 range; I changed my home range to 10.0.0.0 and voila!

Additionally, I added 192.168.1.0 with netmask 255.255.255.0 as a local route to the VPN and checked 'use VPN only for routes on its network'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.