Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed a fresh install of Ubuntu 12.10 and this is my first Ubuntu install. I have a Dell Inspiron 6400 and my wifi is turned off and cant seem to switch it on. I searched a lot on it but can only find answers for Ubuntu 12.04 :( can someone help me please? Thanks in advance

share|improve this question
    
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Dec 1 '12 at 20:37
add comment

4 Answers

I have the same problem and this was printed:

lo        no wireless extensions.

eth0      no wireless extensions.

The main problem was that I didn't check the "Install third party stuff" when my Ubuntu was installing. So I ran the following command:

sudo software-properties-gtk

Went to Additional Drivers tab and checked to use any proprietary driver I want.

Source: http://www.upubuntu.com/2012/10/to-do-list-after-new-installation-of.html

share|improve this answer
add comment

I had the same issue and this is what worked for me:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree

Source: http://catlingmindswipe.blogspot.com/2012/07/broadcom-wireless-fix-for-ubuntu-1210.html

share|improve this answer
add comment

Welcome to Ubuntu world. question you asked has a broader concept, i may require few answers from you :

  1. have you checked id your WIFI LED is glowing (or some other mechanism that lets you know that your WIFI is on).

  2. reply with what you see as a result of iwconfig on commandline.

Meanwhile you can try :

  • Disable the non supported driver.
  • Go to Synaptic and install b43-fwcutter and firmware-b43-installer.

Thanks.

share|improve this answer
add comment

PLUG IN ETHERNET CABLE

run these commands in terminal

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

sudo apt-get update

sudo apt-get install b43-fwcutter firmware-b43-installer

THEN UNPLUG ETHERNET AND REBOOT

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.