Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The issue has begun within 12.10. Before it worked perfectly. Now, even restarting alsa won't work, I have to reboot.

Please, ask for details. I'm running Ubuntu 12.10, unity DE with gnome 3.6, no third parts drivers.

Thanks

Here you are with sudo lshw output: http://pastebin.com/vh3SGcZa


I've tried removing and readding the audio kernel module - however

Can't sudo modprobe -r snd_hda_intel. It gives FATAL: Module snd_hda_intel is in use

Here you are with /etc/modprobe.d/alsa-base.conf content: http://pastebin.com/yvArB2ex

My laptop model is HP 6730s


In /var/log/syslog I found the following:

kernel: [   33.847111] pci_pm_runtime_suspend(): azx_runtime_suspend+0x0/0x40 [snd_hda_intel] returns -11

cat /sys/module/snd_hda_intel/parameters/power_save gives 0 cat /sys/bus/pci/devices/0000\:00\:1b.0/power/control gives on

pacmd list-sinks:

Welcome to PulseAudio! Use "help" for usage information.
>>> 1 sink(s) available.
  * index: 0
    name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9959
    volume: 0: 100% 1: 100%
            0: 0,00 dB 1: 0,00 dB
            balance 0,00
    base volume: 100%
                 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 0,00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le ch 2 48000 Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0,00 ms; range is 1,00 .. 341,33 ms
    card: 0 <alsa_card.pci-0000_00_1b.0>
    module: 4
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "AD198x Analog"
        alsa.id = "AD198x Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel"
        alsa.long_card_name = "HDA Intel at 0xd8900000 irq 49"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.name = "82801I (ICH9 Family) HD Audio Controller"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Stereo analogico"
        device.description = "Audio interno Stereo analogico"
        alsa.mixer_name = "Analog Devices AD1984A"
        alsa.components = "HDA:11d4194a,103c3614,00100400 HDA:11c11040,103c1378,00100200"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output: Uscita analogica (priority 9900, available: unknown)
            properties:

    active port: <analog-output>
share|improve this question

closed as off topic by Jorge Castro, Ringtail, Anwar Shah, Stephen Myall, hhlp Jan 11 '13 at 10:47

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
The pastebin links are broken. –  jdthood Dec 17 '12 at 14:50
    
they had expired, now I pastbined them again! –  jasmines Dec 17 '12 at 14:58
    
I had similar problem, updating (or was it removing, reinstalling some sound packages?) fixed it for me. –  NoBugs Dec 18 '12 at 7:19
    
Does restarting pulseaudio, using 'pulseaudio -k' help? –  David Dec 18 '12 at 8:56
    
It doesn't. I added a new edit, maybe this can help you finding out the problem! –  jasmines Dec 18 '12 at 8:57

3 Answers 3

Have you tried the following operations?

sudo gedit /etc/pm/sleep.d/50alsa

Add the folloowing lines into the file.

case "$1" in
        hibernate|suspend)
                # Stopping is not required
                ;;
        thaw|resume)
                /sbin/alsa force-reload
                ;;
        *) exit $NA
                ;;
esac

Press Ctrl+S to save this file,then make executable this file with the following command.

sudo chmod +x /etc/pm/sleep.d/50alsa
share|improve this answer
    
Executing manually /sbin/alsa force-reload won't solve, therefore I think this script won't too. –  jasmines Dec 14 '12 at 15:35
    
There are bug reports in Launchpad reporting similar symptoms. E.g., bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1066488, bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1076980 –  jdthood Dec 17 '12 at 15:00
    
This helped me on Ubuntu 13.04. –  Stefan Radovanovici Sep 27 '13 at 14:49

The error in your log seems to suggest there was a problem whilst suspending the sound card. Have you checked whether Linux is setup to suspend the sound card, or whether power saving is disabled? Reading through a few pages on the topic, I think the following information might be helpful.

Check for Power Saving in the HDA-Intel Driver:

cat /sys/module/snd_hda_intel/parameters/power_save

https://lesswatts.org/tips/misc.php

Check options for Power Saving, using the PCI interface:

cat /sys/bus/pci/devices/*/power/control  # '*' should match the sound card's PCI Address, as listed in 'lshw'

Check the current state of the sound card, according to Pulse Audio:

pacmd list-sinks     # Look for 'suspend', 'suspend-cause' and 'alsa.card_name'

http://en.wikibooks.org/wiki/Configuring_Sound_on_Linux/Pulse_Audio/Testing

share|improve this answer
    
find the requested outputs in the question –  jasmines Dec 19 '12 at 12:00
    
Okay, I guess that is not the problem. Last suggestion, have you tried using any of the available options for the 'AD1984A' codec? shanky.org/2011/09/26/ubuntu-and-hp-touchsmart-sound –  David Dec 19 '12 at 15:32

The error code -11 means -EAGAIN. According to the current source code

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=sound/pci/hda/hda_intel.c

Several things changed between 3.7 and trunk. The specific return value does not exist in this method in the trunk. It's likly the problem is already fixed upstream. You can test using a daily (or wait for rc's) mainline kernel to confirm this. If everything works, you might just use that kernel. If not, you can report your findings to the mentioned bug entry (https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1066488) to help developer get it fixed...

share|improve this answer
    
I've already tried 3.7 provided by xorg-edgers, but it didn't fix this bug, and moreover gave kernel panic on resuming ac adapter from battery. –  jasmines Dec 20 '12 at 16:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.