Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was having the annoying problem that pressing f10 on a terminal brought up the mouse menu. So, I searched for a solution here, which led me to this,

How do I deactivate F1 and F10 keybindings?

Disable F10 in gnome-terminal in 12.04 Type this in the console:

mkdir -p ~/.config/gtk-3.0 cat< ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation { unbind "F10" }

  • { gtk-key-bindings: NoKeyboardNavigation }

EOF Then close all terminal sessions. Now it should work as it should (in mc for example).

After trying Paweł Gościcki's solution, none of the keyboard settings that I ask for, via System Settings > Keyboard, are having any effect. For example, the setting to change keypress delay does not work and delay is very long. The "Make Caps Lock an additional Control" does not work either. How do I get the keyboard settings to work again? Thanks!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.