Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.10 and Gnome-Shell 3.6.

Everything worked fine till the moment I've began to customize the main menu (apps wich appears in Dash and so on).

I don't know wether I've done something wrong or if there is a bug : suddenly, the Dash became empty. My favourite docks too, except the "Show apps" button. When I activate it, there is only an empty dash, no apps showed. The only way I can access an app is using the "Alt+F2" shortcut. I've tried to restart gnome-shell (Alt-F2 / r) but nothing has changed... A logout and a reboot have not changed ...

Do you know how to repair the gnome-shell ?

Thanks for your help...

share|improve this question
    
It's difficult to say without knowing what you mean by the 'dash' ('overview' maybe?) or how you tried to customize which apps appear (which programs you used, ...). –  astex Nov 1 '12 at 20:42
    
Excuse me : I mean the overview... Gnome-Shell displays none apps in the overview. All my favourites disappear too. It seems to be a config problem: I've re-installed the OS, and the problem remains...Unity works well. –  Ratoune2008 Nov 2 '12 at 0:10

3 Answers 3

Finally, I've discovered that the problem came from Alacarte (menus). I've found the solution in the Archlinux Forum, here. It seems that Alacarte creates a ~/.config/menus folder. When deleting this folder, Gnome-Shell recoveres its usual Apps overview and the customized Favourite Ones.

Thanks a lot for your interest and answers...

share|improve this answer

I was facing the same with Gnome-shell on ubuntu 12.10. (with gnome2)

It used to work with "gnome" & "gnome classic (no effects)"

To make it work with "gnome classic" ((my preferred window manager), I had to follow below steps.

compizconfig-settings-manager Install compizconfig-settings-manager Install via the software center

  1. sudo apt-get install compizconfig-settings-manager
  2. On command line/alt+f2 enter ccsm (or open compizconfig-settings-manager from applications menu)
  3. On left side categories, select window management.
  4. Select your preferred window switcher. & Enable it.

I hope it helps someone. I had struggled for 2-3 hrs for it. :-)

share|improve this answer
    
Thanks a lot Anishane ! I've not tried with ccsm... as i've finally found that Alacarte was the problem (see my answer above). I do hope your answer will help some others... –  Ratoune2008 Nov 2 '12 at 22:39

thank you ratoune !!

this worked. just delete the menus file (~/.config/menus) and reboot

https://bbs.archlinux.org/viewtopic.php?id=137590

thanks again.

share|improve this answer
    
You're welcome ;-) Since November, I have no more problem with that... Do hope it will be the same for you and enjoy ! –  Ratoune2008 Jan 19 '13 at 0:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.