Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I’m on Ubuntu 12.10 and I’ve seen that I can use

sudo dpkg-reconfigure keyboard-configuration

to control which key triggers the dead key behaviour on my keyboard (which normally resides on AltGr). I would like to use both Alt as well as AltGr to type dead keys.

However, when I select “Both Alt Keys“ in the “Key to function as AltGr” step, the alt-tab application switcher shortcut stops working, presumably because the key combo is swallowed by whatever controls text input. Is there any way to make both work, since there is no dead key on tab?

share|improve this question

closed as too localized by jrg Nov 10 '12 at 22:33

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is that for 'dead key' configuration, or is it to switch to different keyboard layouts? –  user4124 Nov 4 '12 at 16:33
    
@user4124 I don’t quite know what you’re getting at: The utility I mentioned lets me change keyboard layouts. Some layouts have dead keys and some of these are activated only with AltGr pressed. One screen in said utility lets me choose which key to use for “AltGr” (if not AltGr). I can choose to use “Both Alt Keys”, which is what I would like to use as it mimicks how the Mac’s dead keys work. Unfortunately, this makes alt-tab inoperable for app-switching even though there is no dead key on tab. I would like to use both the app-switcher as well the dead keys with left alt. –  Raphael Schweikert Nov 4 '12 at 19:15
    

1 Answer 1

Short answer: Unfortunately, you can't.

Long answer: Technically, if you change the left alt's function, you would have to also alter the Application switcher's keyboard shortcut to something that doesn't use the alt keys.

Finally, I don't know if you're aware that you can also use the System Settings > Keyboard Layout > Options... to edit all kinds of keyboard layout related stuff.

share|improve this answer
    
So I can change the app-switcher’s keyboard shortcut? That would be useful as well: I could get used to windows-tab instead. Where do I change this? –  Raphael Schweikert Nov 4 '12 at 19:16
    
Yes you can. You can customize (probably) all of the existing keyboard shortcuts. Go to System Settings > Keyboard > Shortcuts. The App switcher shortcut will be under Navigation > Switch Applications. Change that (and all the other shortcuts that use Alt L) to something else, paying attention to not cause conflicts with existing shortcuts. That should do it. –  Томица Кораћ Nov 4 '12 at 22:36
    
P.S. I'm actually not sure if Super+Tab would work, because Super key is used for many important shortcuts in Unity (Super+Tab is already used to switch between Launcher's icons), so I'm guessing it would cause the same problem for you. But you can always try and let us know the results. –  Томица Кораћ Nov 4 '12 at 22:39
2  
A recent update seems to have killed Unity on my machine so I can’t verify any of these suggestions but am going to award the bounty anyway. –  Raphael Schweikert Nov 9 '12 at 7:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.