Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu (not Xubuntu) and am using Xfce4 on my laptop. When my laptop battery is critically low, Ubuntu/Xfce4 performs some action (perhaps hibernate?) which causes my laptop to shut down.

However when I start it again, it never comes up. I don't even get BIOS or anything on the screen, it is completely black. The only way to get it back up is to take it apart, remove the internal CMOS battery as well as the main battery, wait a few minutes, and put it back together.

Obviously this is not optimal.

How do I disable all actions when the battery is critically low? I would rather have it run out of power, than ending up in this error condition.

share|improve this question
    
Ubuntu doesn't support both hibernation and encrypted home folders enabled at the same time. This fact is kept secret from the user, to many people's dismay and frustration (when your betteries runs out the system effectively powers off the system, without giving you a chance to save your work)... you can try enabling the hibernation using this link: help.ubuntu.com/community/EnableHibernateWithEncryptedSwap (it works for me). But at the cost of typeing password twice when the system boots up - once to unlock swap, and second time to login. –  Adam Ryczkowski Jul 13 '13 at 21:15
    
hey could you tell us what model your laptop is? Also did the chosen solution work? I would like to debug this issue if I get my hands on a similar model. Seems to be quite a critical bug. Thanks. –  staticd Mar 23 at 10:31

2 Answers 2

up vote 6 down vote accepted

I have no idea how to do it for XFCE but for GNOME, you can change it by installing dconf-tools. Open dconf-editor Go to:

org > gnome > settings-daemon > plugins > power

and edit critical-battery-action value to nothing.

You can also un-check use-time-for-policy. Then your system won't use the time remaining as the criteria. It will be forced to use the percentage remaining. Takes care of a bug in ACPI.

There should be something similar for XFCE.

share|improve this answer

go to power settings and choose " power off" for the option of when power is critically low

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.