Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So i have installed synaptic package manager.. via it, i have checked once libopencv-highgui-dev and applied complete removal.. after that i installed it... now everytime i try to install an application e.g Format Junkie

sudo add-apt-repository ppa:format-junkie-team/release && sudo apt-get update && sudo apt-get install formatjunkie

in the command install format junkie it gives me that error everytime:

     sudo apt-get install formatjunkie
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopencv-features2d-dev : Depends: libopencv-highgui-dev (= 2.3.1-11ubuntu2) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

What should i do? And 2nd what did i did wrong so it won't happen another time?

output of lsb_release -a

No LSB modules are available.  
Distributor ID: Ubuntu   
Description:    Ubuntu 12.10  
Release:    12.10  
Codename:   quantal
share|improve this question
    
Can you add the output of lsb_release -a to the question (not a screenshot, just copy/paste). –  mikewhatever Nov 1 '12 at 11:47
    
Added in the description –  Leon Vitanos Nov 1 '12 at 11:54
    
So, why was it necessary to remove libopencv-highgui-dev and then reinstall it? Can you double check it is installed. –  mikewhatever Nov 1 '12 at 12:01
    
I was compiling my project and it gave me an error for a missing lib.. so installed it but it wasn't this one the problem... so i complete removed it.. and then i installed libopencv-dev (which has libopencv-highgui-dev in it).. yes it is installed: i.imgur.com/YnpJt.png –  Leon Vitanos Nov 1 '12 at 12:07
    
When quoting errors from the terminal, it is preferred to copy-paste instead of screenshots since it is easier to read and interpret for us.\ –  hexafraction Nov 1 '12 at 12:40

2 Answers 2

up vote 1 down vote accepted

Open /var/log/dist-upgrade/apt.log

identify Broken packages , open terminal and execute following commands.

First Remove that broken packages completely (remove if any other remain)

sudo apt-get remove --purge libopencv-highgui-dev

System Update and upgrade packages

sudo apt-get update && sudo apt-get upgrade

Fix Dependency using this command

sudo apt-get install -f 

Remove unnecessary packages

sudo apt-get autoremove
share|improve this answer
    
folder dist-upgrade is empty.. sudo apt-get --purge libopencv-highgui-dev will give me E: Invalid operation libopencv-highgui-dev –  Leon Vitanos Nov 1 '12 at 12:58
    
Try the now-changed command in the answer, see if that works, @Bong.Da.City –  Thomas W. Nov 1 '12 at 13:18
    
With your edit i can now install format junkie :) –  Leon Vitanos Nov 1 '12 at 13:56
    
Patel: the --purge argument requires the remove directive first. Just a note for future reference ;) –  Thomas W. Nov 1 '12 at 14:54
    
ooo and what if i want to have these libs installed and format junkie? ( as i said i want the libs so i can compile a programm called wallch )... see what it shows me when i try to install libopencv-dev (i.imgur.com/hREGE.png) –  Leon Vitanos Nov 1 '12 at 15:11

Try doing this: apt-get install formatjunkie libopencv-highgui-dev=2.3.1-11ubuntu2 libopencv-features2d-dev

That should force it (don't forget sudo!) to try and get the version it requires.

If not, I'll take a look at that package, it may just be broken in the PPA (I'm one of the uploaders to that PPA, if you read the uploader entries :P)

share|improve this answer
    
O you are the one that maked our ppa? :) I am the other developer of format-junkie.. Anywho i solved my problem with the answer of K.K Patel that u edited :) Could u tell me what i did wrong and all this happened? Should i apply removal and not complete removal? What is the difference? –  Leon Vitanos Nov 1 '12 at 13:56
    
The issue was likely a bug in the system, the command that Patel gave omitted the 'remove' command which is necessary (the --purge argument requires the remove command). The other issue is the system wasn't installing the right version (I've seen that happen before). And yes, I upload the packages to the PPA whenever the other dev pushes a code change to the bzr branches on Launchpad. (I'm working on porting to Raring now) –  Thomas W. Nov 1 '12 at 13:58
    
Anyone? and what if i want to have these libs installed and format junkie? ( as i said i want the libs so i can compile a programm called wallch )... see what it shows me when i try to install libopencv-dev (i.imgur.com/hREGE.png)... and if install it and it removes format junkie.. then when i try to install format junkie it shows me the same error as my 1st post... –  Leon Vitanos Nov 2 '12 at 11:39
    
You seem to be wanting to install something that is incompatible. The package installs the bare essentials. If you want to use custom libs outside those defined in the packaging, you'll need to build formatjunkie from source. I can't make packages work with each other when they're incompatible. The libs you specify are marked as "Incompatible" with the libs installed by the package. You and I should communicate on IRC or a chat channel in here, or email, to discuss this... –  Thomas W. Nov 3 '12 at 5:00
    
@Bong.Da.City bugs.launchpad.net/format-junkie/+bug/1074575 <-- Go to that bug, and read up. Also, you should subscribe to the bugs on the bugtracker there on launchpad. –  Thomas W. Nov 3 '12 at 8:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.