Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Ubuntu 12.10 PC. When I plug in my internet cable it starts connecting and after a minute it says it can't connect. I tried different cables but nothing works. Wlan works. I think it's the network driver but I don't know how to install/update it. Here's the ifconfig info (if it helps):

eth0      Link encap:Ethernet  HWaddr 00:01:6c:39:2a:8d  
      inet6 addr: fe80::201:6cff:fe39:2a8d/64 Scope:Link
      RX packets:2011 errors:0 dropped:362 overruns:0 frame:0
      TX packets:586 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:175452 (175.4 KB)  TX bytes:147211 (147.2 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:9779 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9779 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:8460080 (8.4 MB)  TX bytes:8460080 (8.4 MB)

wlan0     Link encap:Ethernet  HWaddr 08:10:74:35:99:9d  
          inet6 addr: fe80::a10:74ff:fe35:999d/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1790 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3250 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:401664 (401.6 KB)  TX bytes:2898773 (2.8 MB)
share|improve this question
show me configuration of /etc/network/interfaces – K.K Patel Nov 1 '12 at 12:21

I had the same problem - and for some reason couldn't duplicate it with any kind of consistency. It would just stop working for a bit, then work again, then stop again. Pretty annoying.

I went into the Network Settings and ignored IPv6, and it seems to have fixed the problem. Haven't had an outage since I did this. Maybe it'll help? As always, YMMV.

Happy holidays!


share|improve this answer

My problem was similar: Ubuntu 12.10 aka Quantal Quetzal and at first I had a wired connection and after installing updates the connection was no more. I did everything I could retrieve from the internet to solve this: settings of the connection, drivers (via USB stick), altering obscure files etc.

But one thing suddenly struck me: what if the problem does not come from the inside of the system? ROUTER! I restarted the router and voila, problem solved. Than I had some other fun problems to solve, but it worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.