Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, whenever I try to search for updates with Ubuntu 12.10's update manager, I always get this error: Failed to download repository information, followed by the following details:

W:Failed to fetch Unable to connect to

, W:Failed to fetch Unable to connect to

, W:Failed to fetch Unable to connect to

, W:Failed to fetch Unable to connect to

, W:Failed to fetch Unable to connect to

, W:Failed to fetch Unable to connect to

, E:Some index files failed to download. They have been ignored, or old ones used instead.

Initially I thought that for whatever reason the repositories were down, so I switched from the Canada server to the main server. I still got the same error. I also tried installing some things from the ubuntu software center. Funny thing is, that worked fine and I was able to successfully download and install software from the software center, so it seems that only update manager can't access the repositories.

I have searched for and found similar cases (relating to ubuntu 12.10), but most of those cases involved ppa's, and I don't use any ppa's.

Help would be appreciated. Thanks.

share|improve this question

closed as off-topic by bain, Luis Alvarado Jul 24 '14 at 22:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – bain, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

If you are using a proxy, you will not be able to use the Update Manager without configuring your system appropriately.

The Ubuntu Update Manager uses the same proxy configuration as apt-get, the problem with this is that the system proxy setting does not alter the apt-get proxy setting. This must be done manually by editing sudo nano /etc/apt/apt.conf and add the relevant data. An example of a http proxy server is

Acquire::http::proxy "http://username:password@proxy:port/";

Make sure that your password does NOT contain any non-ASCII chars as this might create some problems due to the files encoding.

share|improve this answer

I am using the GNOME desktop and was having the same problem. Here's what I did:

  1. I went to Administration and started Software Updater.

  2. I then clicked on Stop for it to stop updating. It went to saying I canceled updating then had a tab to the left for settings.

  3. I clicked on Settings the screen came up.

    • Under Ubuntu software, I unchecked everything then checked the top three under downloadable from the Internet:

      • canonical supported
      • community maintained
      • proprietary drivers (I have a video card that can use these drivers)
    • Under other software I unchecked all

    • Then checked the first two canonical partners
    • I then closed Software Sources out and then restarted Software Updater
    • I waited to see if it worked and it did
  4. I made a few adjustments before doing this but the adjustments never worked.

    I went to the web page that failed to load by typing in the address in the web browser I was using. I then clicked on the links to go down through the web pages the Software Updater could not go to before I changed the settings in Software Updater.

  5. Then back to Other Software

    Once the Canonical sources worked under other Software, I added the other software sources one at a time then closed it out and run Software Updater.

    My other sources were:

    • independent provided by other software
    • added by software center ryzom
    • added by software center pct-listen
    • added by software center lord of ultima

    Under Update tab:

    • check only important security updates and recommended updates

    Under additional drivers I am using:

    • x server - AMD/ATI display driver wrapper

I am not a expert at Linux but hope this helps.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.