Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

hud-service keeps eating my cpu. This is troublematic, specially because I'm running 12.04 in a Asus EEEPC. There are a lot of answers on how to change hud bindings, but what I reallyw wonder if there is a way to disable or uninstall hud-service.

Thanks in advance, Marcos

share|improve this question
    
You're not new to askubuntu, so is it safe to assume you're not interested in xubuntu or lubuntu (a lighter desktop environment)? – Rucent88 Nov 1 '12 at 6:11
1  
@Rucent88 nope :3 – Marcos Roriz Junior Nov 1 '12 at 12:19
2  
You answered "nope" to not being interested in lighter desktops, which would mean "yes, I am interested in a lighter desktop". But I'm inclined to think that wasn't what you meant to answer... – Rucent88 Nov 1 '12 at 12:57
1  
my bad, I actually mean I'm not interested :) – Marcos Roriz Junior Nov 2 '12 at 1:55
    
The hud is actually a really neat feature - searching all the menus, it's like a shortcut finder. – NoBugs Nov 12 '14 at 4:58
up vote 17 down vote accepted

Open a terminal and do

on 32bit system

sudo chmod -x /usr/lib/indicator-appmenu/hud-service

on 64bit system

sudo chmod -x /usr/lib/x86_64-linux-gnu/hud/hud-service

which removes - the execute mode x (i.e., permission) from hud-service.

Done.

You may want to gently end (or violently kill) the currently running hud-service (or reboot, etc) for "changes to take effect" immediately...

share|improve this answer
    
I'll try that today! – Marcos Roriz Junior Nov 16 '12 at 17:35
    
I tried already :-) and no hud-service exists in resources (system monitor). – NikTh Nov 16 '12 at 18:47
12  
on 64-bit linux (13.04) it's in /usr/lib/x86_64-linux-gnu/hud/hud-service – knb Sep 23 '13 at 10:57
1  
How to revert these changes? – Saeed Zarinfam Nov 5 '14 at 18:11
3  
@SaeedZarinfam sudo chmod +x instead of -x – NikTh Nov 5 '14 at 19:11

You may want to read this answer here on a similar thread:

http://askubuntu.com/a/693203/223872

The HUD is related to the Unity Launcher. For example it analyzes the files you are using and offers them when you press Super.

On my system (Ubuntu 15.10) the hud-service started using 100% of one CPU.

I solved this by installing Compiz Config Settings Manager (ccsm) and disabled all effects and set "Enable Low Graphics Mode" in "Ubuntu Unity Plugin":

sudo apt-get install compizconfig-settings-manager
ccsm

Although you can indeed disable the executable bit, when the system upgrades, it may reset that bit to on when the file is overridden on new updates.

Also, the comment above the one I posted above mentions that the hud-service is in the package hud, which if you just don't want, it might be better to just remove the package entirely.

http://askubuntu.com/a/699888/223872

share|improve this answer

In my case I used the ubuntu unity plugin to diable the alt key trigger for that service. It might just be what you want to do.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.