Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A picture is worth a thousand words... so does anyone know how to fix this font blurriness in Firefox?

(You'll need to right-click the picture below go to View Image to view it full-size; it's too small to see anything here.)

1

Note: My other applications (and the Firefox non-client area, as you can see in the screen) are completely fine, so obviously going to System->Appearance and changing the font settings isn't fixing the situation.


Edit:

Not letting web pages to use their own fonts also doesn't help:

1

See how the upper one is still sharper?

Also, Firefox's own menu bar doesn't render the same way as the page content (menu bar below, page content above). They're both Segoe UI:

1

share|improve this question
1  
I always had that issue with the default firefox config on Ubuntu, my solution was to disable the "Allow pages to set their font" option, there is an old bug about this: bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/220568 . –  João Pinto Jan 11 '11 at 11:23
4  
I'm always amazed by how many people seem to feel subpixel smoothing is "blurry" or harder to read... –  DisgruntledGoat Jan 11 '11 at 15:36
1  
@DisgruntledGoat: Both Windows and Linux above perform subpixel smoothing, what's different is the hinting mechanism. –  Mladen Jablanović Jan 11 '11 at 15:54
3  
The Windows version is "sharper" yes, but also, more pixelated, uglier and more distracting. But seriously, this is a taste thing, folks. –  frabjous Jan 11 '11 at 21:24
1  
I was talking about relative pixelation of one versus the other. But never mind that. You can of course set SegoeUI as your default font on webpages (under Edit > Preferences > Content > Fonts & Colors), but if the website requests something else, it'll get it, unless you make it so that websites never get to use their own fonts, which I wouldn't recommend. For a compromise, you can use something like the Stylish plugin to get your favorite fonts on the sites you use most often. There's even a UserStyle for "Google in SegoeUI": userstyles.org/styles/6896 –  frabjous Jan 11 '11 at 21:53
show 7 more comments

9 Answers 9

up vote 4 down vote accepted

All right, I found the solution:

It was all because I was using the Segoe UI Light font everywhere in the system, but Firefox was using Segoe UI Regular. By (hackishly) changing the font in About:Config, I managed to get it to look almost the way I wanted... but now, the font spacing is too low and things are squished together.

If anyone knows how to increase the spacing, that would be fantastic! :)

share|improve this answer
add comment

Linux and Windows render fonts differently, so you can't expect to have same font in Windows and Ubuntu rendered the same. This is also an issue on Mac, and there are lots of articles around discussing the difference.

Generally, this Wikipedia article is a good starting point for reading

If you are bothered, you can play with "Hinting" section in Gnome appearance settings (Font tab).

PS: To illustrate the fact that this is not Firefox issue, here's a screenshot I made in gEdit, using Arial 10pt font. You will see that it's rendered exactly the same as in Firefox screenshot you've posted:

Screenshot from gEdit

Another screenshot, now gedit and FF side-by-side:

FF vs gEdit

share|improve this answer
    
I have tried -- again, the issue isn't with every application, it's just with Firefox, and just with the web content (no issue with the toolbars and such). –  Mehrdad Jan 11 '11 at 19:09
    
Are you sure you are talking about the exact same fonts that you consider well rendered in Linux? By default, Linux doesn't use MS fonts which you are comparing in browser (Arial, in particular). For comparison, make a screenshot using the same font (say, Arial or Verdana) in gedit and notepad. I am pretty sure Firefox doesn't render fonts differently than rest of Ubuntu. –  Mladen Jablanović Jan 11 '11 at 19:16
    
@Mladen: "I am pretty sure Firefox doesn't render fonts differently than rest of Ubuntu." Except that it does. (I've found the problem all around the net, but not the solution.) –  Mehrdad Jan 11 '11 at 19:27
    
Take a look at the screenshot I have just posted. –  Mladen Jablanović Jan 11 '11 at 19:28
    
@Mladen: Take a look at my screenshot. (And could you please post the screenshot of the same text for yours, but in Firefox? You can't really compare just one thing...) –  Mehrdad Jan 11 '11 at 19:34
show 4 more comments

Mehrdad: I think you've answered your own question now (that the two screenshots are showing different fonts/weights)!

The main lesson here is that currently Firefox does its own thing with font rendering and doesn't pick up the same font preferences set in GNOME or KDE. There's bug #621198 ("Check+Harmonise X/Fontconfig/Gtk+/Firefox/Chromium/Konq/Qt/KDE rendering preferences") to try and fix that.

On the subject of font rendering preferences themselves; it's very subjective. A low-resolution display (as compared to a 600 DPI laser-printer) does not have sufficient pixels to render the glyphs in their original form. The choices are either to anti-alias/grayscale the text, or to intentionally distort the text to fit the pixel-grid (called "hinting").

  • Geometric accuracy (aka "blurry") is the Mac OSX historic default
  • In the middle (aka "slight hinting") is the Ubuntu historic default
  • Fully hinted (aka "sharp") is the MS Windows historic default

People tend to prefer what they're used to; it's possible to argue equally that each is better/worse than the others. Ubuntu ships with a default in the middle of the two extremes applying a default of hinting in the vertical direction only.

In addition, most platforms now use sub-pixel rendering, which makes use of knowledge of the orientation and physical characteristics of the monitor to attempt to display more detail in the letters—at the cost of colour fringing. You can configure all of these settings under Ubuntu to your own liking, but you are currently required to apply them again for Firefox/Chromium until the bug above is fixed.

share|improve this answer
add comment

I've been trying to fix this problem for two years now, and my only solution has been to force Firefox to use my selected fonts. Not ideal, but better than the Firefox defaults. And the thing that drives me completely insane is that, if you install Opera under Linux and compare its font rendering with the same page in Firefox under Windows, the pages look virtually identical.

I've asked before, and I'll ask again here and now: How is it that Firefox can get it right in Windows, and Opera can get it right under Linux, but Firefox can't get it right under Linux?

Given that Opera gets it right, I'd say this ISN'T an issue with system fonts, especially since I have a complete set of Microsoft TTF fonts installed on my Linux box. The web page tells the browser what fonts to use and the browser should use them - if Opera can find and use them on my system, FF should too. This is a FIREFOX BUG, I reported it to them a long time ago, and after at least two years it's way past time they got their act together and fixed it.

share|improve this answer
add comment

Make sure there is no zoom active (ctrl + 0)

share|improve this answer
    
There isn't any zoom. –  Mehrdad Jan 11 '11 at 19:11
add comment

This might also happen due non-availability of MicroSoft fonts. Install MScoreture fonts.

sudo apt-get install msttcorefonts

share|improve this answer
    
I am couldnot see the picture, it is blocked at my office firewall. Mine answer is guess, as i have faced a similar problem in past, but installing fonts solved it for me. –  Vivek Sharma Jan 11 '11 at 13:16
    
But this isn't a Firefox solution! Every other application is fine, I don't need to mess up other things! Why exactly would a Firefox solution need a system-wide change? –  Mehrdad Jan 11 '11 at 19:11
    
I actually think it might help to remove msttcorefonts, or generally, the Windows fonts. The screenshot shows the same fonts, but Windows has a special hinting mechanisms for its own fonts. If the problem is font-specific rather than application-specific, that might explain why the titlebars (which are presumbly not using Arial or other MS fonts) look different. –  frabjous Jan 11 '11 at 21:32
add comment

Have you tried swapping in the .fonts.conf file found at the bottom of this page on the Ubuntu Wiki.

Here's a description of the problem, which sounds like yours:

I'm currently working on font settings in XML (.fonts.conf). I noticed that after installing msttcorefonts things don't look quite as good in Firefox anymore. Most web pages request Arial which doesn't get hinted and anti-aliased too nicely, especially on LCD screens. I personally prefer the "sharp" non-anti-aliased look. I also noticed that many users coming from Windows® ask on the forums about getting fonts to look that way.

share|improve this answer
add comment

https://bbs.archlinux.org/viewtopic.php?id=59507 Post #3.

I don't know why but it did fixed my Firefox font rendering.

share|improve this answer
    
Welcome to Ask Ubuntu! While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. –  Peachy Sep 30 '12 at 4:19
add comment

Well, I deleted .font_config and rebooted. Seems to fix the problem.

Edit from comment:

Finally! Found a solution that works for me. Seems the problem is with the Ubuntu font family. I went to System>Preferences>Appearance>Fonts and changed the fonts to something else than Ubuntu's own, eg. Sans, serif etc etc. Hopefully this will work for you guys too. – Atle Jul 11 '11 at 18:25

share|improve this answer
    
Sorry spoke too soon... Seems this problem 'grows' with time. Deleting the file worked for a short while, but after some use the problem comes back. The funny thing is that this problem reminds of a problem I was unable to fix a few years ago. Then the problem was characters being gradually replaced by black squares.... –  Atle Jul 11 '11 at 18:12
    
Finally! Found a solution that works for me. Seems the problem is with the Ubuntu font family. I went to System>Preferences>Appearance>Fonts and changed the fonts to something else than Ubuntu's own, eg. Sans, serif etc etc. Hopefully this will work for you guys too. –  Atle Jul 11 '11 at 18:25
    
Hello Atle. Mehrdad has already changed the interface font away from the default of the <em>Ubuntu Font Family</em> (font.ubuntu.com) to <em>MS Segoe UI</em>. What you're seeing sounds much more like a non-deterministic driver/font rendering cache bug (different to the question that is being asked here). –  sladen Jul 11 '11 at 23:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.