Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two screens connected to my computer. I want applications to start on the screen my mouse cursor is on. How can I set this?

share|improve this question

2 Answers 2

I had wanted to do this myself. Here is what I found:

  1. Go to the CompizConfig Settings Manager (type compiz into the Dash).
  2. Click on the Place Windows item in the Window Management section.
  3. Select Use output device with pointer from the Multi Output Mode dropdown menu
  4. Make sure you also click the checkbox that enables the Place Windows "plug-in"

You may run into trouble with the behavior remaining unchanged unchanged in certain cases. This happened to me, but then I realized the reason: Smart output mode will place a full-screen application on a monitor with a higher resolution by default, even if the "Use output device with pointer" option is selected. To fix this problem, I changed the Placement Mode to Pointer. I also found that the other available options, like Centered, also achieve the result of the window being placed on the screen currently containing the mouse cursor. I recommend trying out each of the options to see which one you personally prefer (personally, I found that I like Centered the best). It seems that Smart mode is trying to be "too smart" for what I want, I believe that it assumes that one wants bigger windows to be placed on the higher resolution screen regardless of what other options are selected, which is not necessarily what one may want in many cases.

I hope this helps!

share|improve this answer

By default the screen with mouse cursor is chosen. If not it can be chosen from display settings in Ubuntu settings.

Just do following steps:

  1. Press Windows or Super button
  2. Type display settings in box
  3. After opening the display select the screen which you want to show cursor by default
  4. That's all
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.