Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP Pavilion laptop with an AMD Radeon HD 6400M graphic card. When I upgraded from 12.04 to 12.10 all was fine and dandy, until I plugged in my TV via HDMI-cable. After a reboot, Unity stopped working and I was getting all sorts of gpu-related error messages.

Well, I consulted Google and while trying to fix this, I kind of went haywire, adding different repositories to install homebrewed solutions, upgrading and downgrading drivers from AMD:s support page, tinkering with settings and so on. It didn't help.

I finally removed all the mentioned repositories, purged all fglrx files and tried to remove all added drivers, but got some dkpg errors.

The situation right now: Unity doesn't work, but Gnome do. Under 'additional drivers', I have the "Advanced Micro Devices [AMD] nee ATI: Caicos [Radeon HD 6400M/7400M Series]" driver. I've tried both X.org, fglrx and fglrx-updates, but still, no Unity.

I've given up trying to fix this myself, I'd rather wait for a working update.

Is there a way to completely reset the graphic drivers to installation default, or do I have to re-install Ubuntu 12.10?

(and before anyone mentions it, NO, I don't want to use Gnome, I like Unity and want it to work.)

share|improve this question

closed as unclear what you're asking by Braiam, guntbert, Eric Carvalho, Richard, Lucio Apr 6 at 22:59

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
delete Xorg.conf –  Naveen Apr 13 '13 at 9:10
    
What are the error messages? –  Braiam Apr 5 at 16:43

3 Answers 3

Ok, Let me just say I was just looking for reviews on the 12.10 drivers before I install and I'm on Windows 8, so not sure if this will help:

  • I do remember if you go to your Ati Catalyst Control Center.. and this is how it is in windows but it's probably the same for Linux/Ubuntu -in the top right corner it says Preferences - Click on that button and then the fourth one down is - Restore Factory Defaults...

  • Your best bet is probably just go back to 12.04 when everything was fine- just reinstall the 12.04 one from the Ati website.

share|improve this answer

This ended up not working for me. There is a better answer at How do I get AMD/Intel Hybrid Graphics drivers to work?

share|improve this answer

It may be the AMD Graphics, perhaps you could use the below to move to Intel Graphics:

edit the /etc/fstab and add the following lines:

tmpfs /dev/shm tmpfs defaults 0 0

none /sys/kernel/debug debugfs defaults 0 0

then edit the /etc/rc.local and add before exit0:

chown $User /sys/kernel/debug/vgaswitcheroo/switch

echo OFF> /sys/kernel/debug/vgaswitcheroo/switch

once you have done that use the attached script & drop it into your /usr/bin folder, and then drop the attached icons into home/$User/.local/share/icons folder

Note: you may want to change the $User in the /home/%User/.local/share/icons element to be the user on your machine. make sure the attached file is executable or it wont work; so either chmod or change permissions by right click.

prior to running the script ensure you have installed gxmessage:

sudo apt-get install gxmessage

To have permanent write permissions to the switch file, add the following line, replacing USERNAME with your username, to /etc/init.d/rc.local:

chown USERNAME /sys/kernel/debug/vgaswitcheroo/switch

then simply run the following command:

switch_between_cards

the switch 1-4 picture attached shows the process and you can see my radeon card is going from off to on to off again

references:

https://help.ubuntu.com/community/HybridGraphics

In addition to solve some dependencies I have add the following to the top of the script:

if [ $EUID != 0 ]; then
    gksudo "$0" "$@"
    exit $?
fi

Note: Thanks to druellan (i have adapted his addition and removed the gnome-session-quit option)

good luck

hope this helps

Here is a link for the switch script:

http://ubuntuforums.org/showthread.php?t=1927317&page=3

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.