Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is it possible to disable Unity 3d in Ubuntu 12.10?

I had to use Unity 2d with Ubuntu 12.04 as Unity would constantly crash and restart. This problem persists in 12.10 with any driver I select in the panel, including the open source driver.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Unity (Unity3d is actually a game engine) is the only UI shell in 12.10, which means, you need to install an alternative before removing it (don't think there ever was a way to disable). Press ctrl-alt-f1 to get a tty, login with your username and password, and install Gnome Classic with

sudo apt-get install gnome-session-fallback

To get back to the login screen, try running sudo service lightdm restart.

You should then be able to select Gnome Classic (no effects) as session from the login scren.

share|improve this answer

I found another solution that works in my case. Deleting ~/.compiz/session before logging in stops Unity from crashing. This file gets recreated when logging out so you have to delete it before each login.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.