Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to dual boot my Windows 8 machine with Ubuntu 12.04 but I cannot even get to the Live CD under UEFI. I've already set my UEFI boot loader to load from the DVD drive before anything else but it keeps on loading Windows 8 first thing. I've checked that the Ubuntu installer I am using is working by setting the BIOS to legacy boot; under this setting, I can get to the Live CD but it cannot detect Windows 8---something I do not want to happen.

Just for the record, my boot order is as follows:

  1. ATAPI CDROM: HL-DL-ST DVDRAM GT51N
  2. USB CDROM:
  3. USB FDD
  4. USB HDD
  5. HDD: TOSHIBA [SERIAL NUMBER]
  6. Network Boot-IPV4:
  7. Network Boot-IPV6
  8. Windows Boot Manager

Has anyone ran into the same problems as me for UEFI? What am I missing here?

Post-resolution update: In a rather embarassing turn of events, it appears that the Ubuntu installer I am using is not even 32-bit. There is no such thing as UEFI for 32-bit.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Most motherboards have an option to launch a boot manager at boot time, typically by pressing a function key (F8, F10, and F12 are all reasonably common). On many UEFI systems, this boot loader includes separate BIOS (aka legacy) and EFI/UEFI boot options for optical discs. Thus, my first recommendation is to try using this built-in boot manager.

Another option may be to disable your firmware's BIOS/legacy boot option. From your description, it sounds like you've found this option and tried setting it to BIOS/legacy mode, but if the option was set to "auto" before, setting it to "EFI" or "UEFI" might get things working.

You could also try installing rEFInd on a USB flash drive and boot from it. rEFInd should scan your system for EFI-bootable media, including optical discs, and enable you to boot them in EFI mode. The trouble is installing to the flash drive is an extra bother, and you might not have any better luck getting rEFInd to launch than you're having with the Ubuntu disc.

A fourth option is to create a USB-bootable version of the Ubuntu installer and try booting from it.

share|improve this answer
    
I managed to boot from rEFInd but it does not display my optical drive (with the Ubuntu installer in it, of course) as a boot option. Are you aware of any issues like this? Anyway, I think this is another question entirely so I'm just asking a new one. –  skytreader Nov 1 '12 at 8:42
    
I've posted a response to your subsequent query at askubuntu.com/questions/210434/…. –  Rod Smith Nov 1 '12 at 16:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.