Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The title really says it all. I haven't been able to change the brightness of my monitor since putting Ubuntu on it. I started off with 12.04 and then decided to see if 12.10 would fix the issue. The internet is also a fair bit slower than I am used to, especially when downloading. Apart from these two issues, everything goes very smoothly.

If anyone could offer any advice or solutions, I would be very grateful.

share|improve this question
    
I am also using the Broadcom driver for my wi-fi. And the proprietary NVIDIA graphics driver. –  user103441 Oct 31 '12 at 17:49

2 Answers 2

Oh, I had the same problem, and the pointer of "Roy Prins" helped me. You can ignore all previous "guidelines". 12.10 works out of box, without any "post-install things". But the only problem is, with nvidia-driver, you lost the backlight control. (That was the only problem I had, on my 2010 macbook air 11 inch. If I use nuoveau driver, it has the backlight, but some vertical lines comes up. So using NVidia driver is the best bet for Macbook Air 3,1.)

The solution for backlight is simple. As Roy pointed out, add option for "EnableBrightnessControl". For example, my /etc/X11/xorg.conf

tailblues@gilsaire:/etc/X11$ cat xorg.conf
Section "Device"
    Identifier  "Default Device"
    Driver      "nvidia"
    Option      "NoLogo"    "True"
    Option      "RegistryDwords"    "EnableBrightnessControl=1"
    BusID       "PCI:2:0:0"
EndSection
tailblues@gilsaire:/etc/X11$ 

And then, it started working for me!

share|improve this answer

Sorry for not providing an answer, but I have a question for you. What tutorial did you follow and what other issues did you experience? I want to do the same thing (latest Ubuntu on a late 2010 Macbook Air 3.2).

There seem to be so many old and half finished tutorials out there that I am unsure how to proceed. Is there a definitive write-up that can be trusted?

Good luck with your issues, I will be checking back.

BTW did you check this:

Look for EnableBrightnessControl

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.