Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using the Docky ppa, and since the latest update it won't start. If I run it from the terminal, this is what I get:

[Info  09:21:19.005] Docky version: 2.1.0 bzr docky r1761 ppa
[Info  09:21:19.024] Kernel version: 2.6.35.24
[Info  09:21:19.026] CLR version: 2.0.50727.1433
[Debug 09:21:19.493] [UserArgs] BufferTime = 0
[Debug 09:21:19.494] [UserArgs] MaxSize = 2147483647
[Debug 09:21:19.494] [UserArgs] NetbookMode = False
[Debug 09:21:19.494] [UserArgs] NoPollCursor = False
[Debug 09:21:19.528] [SystemService] Using org.freedesktop.UPower for battery information
[Info  09:21:19.564] [ThemeService] Setting theme: Transparent
[Debug 09:21:19.587] [DesktopItemService] Loading remap file '/usr/share/docky/remaps.ini'.
[Debug 09:21:19.599] [DesktopItemService] Remapping 'Picasa3.exe' to 'picasa'.
[Debug 09:21:19.599] [DesktopItemService] Remapping 'nbexec' to 'netbeans'.
[Debug 09:21:19.599] [DesktopItemService] Remapping 'deja-dup-preferences' to 'deja-dup'.
[Debug 09:21:19.599] [DesktopItemService] Remapping 'VirtualBox' to 'virtualbox'.
[Warn  09:21:19.600] [DesktopItemService] Could not find remap file '/home/lasse/.local/share/docky/remaps.ini'!
[Debug 09:21:19.602] [DesktopItemService] Loading desktop item cache '/home/lasse/.cache/docky/docky.desktop.en_DK.utf8.cache'.
[Info  09:21:20.101] [DockServices] Dock services initialized.
[Debug 09:21:20.134] [DBusManager] DBus Registered: org.gnome.Docky
[Debug 09:21:20.142] [DBusManager] DBus Registered: net.launchpad.DockManager
Stacktrace:

  at (wrapper managed-to-native) System.IO.MonoIO.Read (intptr,byte[],int,int,System.IO.MonoIOError&) <IL 0x00012, 0x00062>
  at (wrapper managed-to-native) System.IO.MonoIO.Read (intptr,byte[],int,int,System.IO.MonoIOError&) <IL 0x00012, 0x00062>
  at System.IO.FileStream.ReadData (intptr,byte[],int,int) <IL 0x00009, 0x00047>
  at System.IO.FileStream.RefillBuffer () <IL 0x0001c, 0x0002b>
  at System.IO.FileStream.ReadByte () <IL 0x00079, 0x000c7>
  at Mono.Addins.Serialization.BinaryXmlReader.ReadNext () <IL 0x0000b, 0x00031>
  at Mono.Addins.Serialization.BinaryXmlReader.Skip () <IL 0x0003c, 0x00053>
  at Mono.Addins.Serialization.BinaryXmlReader.Skip () <IL 0x00047, 0x0005f>
  at Mono.Addins.Serialization.BinaryXmlReader.Skip () <IL 0x00047, 0x0005f>

And this .Skip () continues infinitely, and very fast. I've tried cleaning the cache and reinstalling docky, but without luck.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It looks like you are experiencing bug #661495.

The fix is in the first comment:

Do this: rm -Rf ~/.local/share/docky/plugins

Then start Docky.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.