Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 (64-bit) directly from the Windows installer. When I start up and select Ubuntu from the Windows boot manager, it correctly passes the command to GRUB, but the GRUB menu does not display - all I see is a blank purple screen. After about 10-15 seconds, the sign-in screen shows up (which means it booted fine).

Is there any way to force it to show the GRUB menu?

share|improve this question
1  
Disabling the graphical screen (setting "GRUB_TERMINAL=console" in /etc/default/grub) does not work. –  SonikkuAmerica Oct 31 '12 at 13:19
    
Does holding down Shift after Windows boot manager show GRUB? Please edit your original question rather than enter new information in comments like the comment above. –  user68186 Oct 31 '12 at 13:23
1  
When you are using wubi, It is not necessary that Grub should be open. –  K.K Patel Oct 31 '12 at 13:39
    
Can you pastebin the output of /etc/default/grub? –  astex Oct 31 '12 at 14:02

1 Answer 1

The grub menu is hidden by default for Wubi installs (on Vista/7, not XP). The reason is that it's not required when the only two OSes are Windows and a Wubi-installed Ubuntu, and it has led to some problems when users assumed they could boot Windows from Grub, when in fact you can't.

If you run sudo update-grub you'll see something like this:

Found Windows 7 (loader) on /dev/sda2
Skipping Windows 7 (loader) on Wubi system

This means that grub considers it to be a single OS situation, and therefore defaults to hiding the Grub menu.

If you want it to show, hold down the Shift key after selecting Ubuntu from the Windows boot manager, or change the settings in /etc/default/grub but I'd have to ask why you want to do this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.