Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Windows 7 as my Host OS which has wired Ethernet working. My guest OS on VirtualBox is Ubuntu 12.04. The problem is that I cannot browse.

I have:

  1. Enabled sharing on Windows;
  2. Have used NAT, Bridged Adapter etc ( all possible combinations);
  3. With NAT, used PCnet-FAST II (Am79c973) combination.

Ubuntu says "connected to wired ethernet1" but I cannot access websites.

VirtualBox Host-Only Network in the Network and Sharing center shows that I don't have IPV4 and IPV6 connectivity.

Meaning I don't have DHCP configured. Strangely I have DNS address correct in the Ubuntu properties.

share|improve this question
    
Please post the content of /etc/resolv.conf on the Ubuntu guest machine. –  jdthood Oct 31 '12 at 15:13
add comment

2 Answers 2

For Internet access you can change network option to this :

enter image description here

I had this problem and solve with this option.

share|improve this answer
add comment

If you still have this issue of networking, try this.

Choose Bridged Adapter as said before boot your guest os (i.e ubuntu).

Try to ping any website from terminal. If you get 'unknown host' as the reply, the issue probably lies at DNS level.

To fix it, go and check if '/etc/resolv.conf' file exits and its contents. You should have atleast one name server entered by Network manager inside the file.

Note: There is also a directory called /etc/resolvconf. we are not concerned about it.

If the above file does not exist, do create one.

$sudo vim /etc/resolv.conf 

and then enter this

nameserver <YOUR_DNS_IP_ADDRESS>

Save the file (press escape followed by : followed by wqa)

Hope internet works now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.