Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are no errors in xsession and I don't have a .bash_login or .bash_profile file, so I'm 100% certain neither of those is loaded and thus cancels .profile loading.

When I rename the .profile to .bash_profile and open a new terminal window, it still doesn't load. Everything in the file works (aliases and PATH exports) when I load it manually via ". ~/.profile", but it won't load automatically.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Looks like this was answered before. You have to be aware of the loading priorities of the files.

[EDIT]

You Have two options:

  1. (Not Recommended) Get your terminal to start as a login shell:
    • open a terminal
    • Go to Edit -> Profile Preferences -> Title and Command
    • activate the "Run Command as a login shell" checkbox This way your .profile is read. But it also messes up the default loading behavior so I would recommend:
  2. Edit or create ~/.bashrc!

Look here for a good explanation about the difference between .bashrc and .bash_profile

share|improve this answer
    
Like I said, the other files do not exist. I only have one profile file, and that's .profile, and even renaming it to .bash_profile does not help. It never even tries to get loaded. –  Swader Oct 31 '12 at 12:39
    
see my edit above, hope it helps –  mrcktz Oct 31 '12 at 12:58
    
This helped, thanks –  Swader Oct 31 '12 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.