Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've isnstalled phpMyAdmin with apt-get install phpmyadmin. When I open "http://localhost/phpmyadmin/", enter "root" as the user name and my MySQL root password and press go, then if I use Firefox, I get offered to download index.php file (and if I agree to download, the file is empty), if I use Opera 11, it says " Connection closed by remote server". What may the reason be and how to fix it?

I use up-to-date Xubuntu 11.04. Reinstalling phpmyadmin did not help, neither did removing AppArmor.

I've tried to use SQLBuddy instead, but there's exactly the same problem. So, I think, the problem is not in phpMyAdmin but in Apache or something.

share|improve this question
    
open localhost to see if your apache works or not, similarly run a php script from command line to check you php, and run mysql from terminal to check if it works, if every components, run then you had some problem with phpmyadmin installation. i had similar problem but i checked all components and completely uninstalled and reinstalled from synaptic package manager and everything works fine –  Santosh Linkha Jan 11 '11 at 5:15
    
@explorex Apache, PHP and MySQL seem to work. –  Ivan Jan 11 '11 at 5:47
    
Going to reinstall, I've run sudo taskserl removelamp-server and it began uninstalling ALL the packages one by one! –  Ivan Jan 11 '11 at 6:17
    
i think you better install one by one package from synaptic package manager(first mysql, then apache, and mysql) and install phpmyadmin. i tried to install phpmyadmin before anything else and had a great crisis ..lol. and also had problem with lampp package ... apache and mysql crashed .. don't know why but with individual i had no problem and i don't know my phpmyadmin also worked somehow.. –  Santosh Linkha Jan 11 '11 at 7:45
    
Because I read you tried a different solution, I'd like to offer another suggestion, maybe after you get your phpMyAdmin working: MySQL Administrator (mysql-admin) and MySQL Query Browser (mysql-query-browser). –  user8290 Jan 11 '11 at 16:44

3 Answers 3

If you download instead of anything else, it is possible with php configuration.

  1. sudo gedit /etc/apache2/mods-available/php5.conf
  2. look for php_admin_value engine off, between and
  3. Add # in front of php_admin_value engine off to disable it.
  4. REMEMBER! Don't change the value php_admin_value engine from off to on!
  5. sudo /etc/init.d/apache2 restart

Wish it helps!

Have a nice day!

share|improve this answer
sudo apt-get purge phpmyadmin
mysql -u root -p

There you have it ;) The best and fastest way to administer your MySQL database. I did this years ago, it was painful initially, but I never looked back.

share|improve this answer

From the README.Debian file:

USAGE

The application will be available at http://localhost/phpmyadmin/ after install if you use one of supported web servers (Apache and Lighttpd at time of writing this). Please note that you need to have enabled PHP support in your webserver (for Apache you can do this by a2enmod php5, for Lighttpd by lighty-enable-mod fastcgi).

You can access this file if you install the phpmyadmin package here: /usr/share/doc/phpmyadmin/README.Debian.gz

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.